Opened 5 years ago

Closed 5 years ago

#10969 closed bug (invalid)

[Debugger] Persist located source file paths

Reported by: bonefish Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When developing e.g. on Linux and using Debugger in a VM the paths of the source code built into the shared objects' debugging info usually don't match their actual location in Haiku, so that one has to tell Debugger explicitly. Alas Debugger doesn't persist that hint, so that one has to do that every time after Debugger has been started. Persisting the info would make the experience more pleasant.

Change History (3)

comment:1 Changed 5 years ago by anevilyak

Type: enhancementbug

Something is broken in your case then, as this has long since been implemented (c.f. FileManager::{Save,Load}LocationMappings()). However, I'm unable to reproduce that problem here. Would you be able to provide a corresponding settings file?

Last edited 5 years ago by anevilyak (previous) (diff)

comment:2 Changed 5 years ago by anevilyak

To be exact, the file of interest would be ~/config/settings/Debugger/Global. Two further questions come to mind: 1) Are other settings such as the UI splits, window size/position being restored properly? and related, 2) are you dropping the binary to be debugged in the same location each time? I'm not entirely certain off the top of my head, but I believe the settings are currently matched up to the debugged team via the on-disk location of the target binary.

comment:3 Changed 5 years ago by bonefish

Resolution: invalid
Status: newclosed

I can't seem to reproduce the issue.

Note: See TracTickets for help on using tickets.