Opened 5 years ago

Closed 5 years ago

#11024 closed enhancement (duplicate)

"Open with" context menu shows paths and duplicate entries

Reported by: waddlesplash Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: #8799 Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

See attached screenshot. I'm on hrev47458, and this has been bugging me for quite some time now. It's persisted across multiple reinstalls, and I'm not quite sure what causes it.

The list of applications (just clicking on "Open with") has the same issue.

Attachments (1)

Tracker_loses_names.png (49.5 KB) - added by waddlesplash 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by waddlesplash

Attachment: Tracker_loses_names.png added

comment:1 Changed 5 years ago by waddlesplash

Has a Patch: set

comment:2 Changed 5 years ago by waddlesplash

Has a Patch: unset

comment:3 Changed 5 years ago by diver

Description: modified (diff)

Most likely haikuporter is running in the background and Open with menu is populated with apps from chrooted /boot/system volume. But yes, it's quite annoying.

comment:4 Changed 5 years ago by taos

I think I once saw something like that when I had mounted a second Haiku installation and my sdcard with Haiku source that I use for building image files. As soon as I unmounted these usb media "Open with" no longer showed paths, just application names.

comment:5 Changed 5 years ago by waddlesplash

Yes, just confirmed this is from HaikuPorter. We should have Tracker ignore symlinks when looking for apps I think.

comment:6 Changed 5 years ago by waddlesplash

Priority: normalhigh

comment:7 Changed 5 years ago by pulkomandy

It's hard to see wether there are actual duplicates in that list with the truncated paths. If you have copies (or different versions) of the same app installed, Tracker will list them all, which sounds like the right behavior. This was already discussed some time ago, and the general opinion is that this only annoys Haiku developers who have copies of all system apps in their haiku generated/ dir.

I can't think of a better solution, since these are not strictly duplicates. We can't hide them, because it's a valid use case to have several different versions of an app installed in different places and with the same executable name. (or maybe they are different apps with the same name. how can we know?)

Showing the path is definitely a feature, since it should allow differenciating the files. However, we could use a smarter truncation to make this more useful.

comment:8 Changed 5 years ago by humdinger

Maybe only have the app name in the menu and put the complete path in a tooltip.

comment:9 Changed 5 years ago by pulkomandy

I think a tooltip over a popup menu is about the worst UI design you can achieve. The tooltip will hide parts of the menu, making it even more difficult to browse.

However we could have extra submenu levels if we really want to overdo things here:

Open with
	StyledEdit
		/boot/system/apps/
		/boot/home/generated/objects/
		/some/other/copy
	DiskProbe
		/boot/system/apps/
		/boot/home/generated/objects/

Where clicking the items at the first level (StyledEdit or DiskProbe) would open the one from system/apps directly. This avoids cluttering the whole menu when only one or two apps have duplicates (only those get a submenu), and keeps it reasonably short even if many apps have dupes.

comment:10 Changed 5 years ago by humdinger

Not sure the tooltip would be "the worst UI design [I] could achieve", people tend to underestimate me in that department. :)

I like your submenu idea.

comment:11 Changed 5 years ago by anevilyak

Blocked By: 8799 added
Milestone: R1/alpha5R1
Priority: highnormal
Resolution: duplicate
Status: newclosed
Type: bugenhancement

Duplicate of #8799.

Note: See TracTickets for help on using tickets.