Opened 5 years ago

Closed 5 years ago

Last modified 14 months ago

#11048 closed bug (fixed)

[acpi_button] stopped working on real hardware

Reported by: jessicah Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

With changes introduced in hrev46302 for ticket #10154, shutdown by ACPI button press no longer works on real hardware. Testing on a 4th gen Intel i3. mmu_man has also reported the same problem on an ASUS board.

Also, in hrev46275 ACPI button shutdown worked with single press. In hrev46280, ACPI button shutdown started requiring two presses to trigger ACPI shutdown (haven't tested inbetween these two hrevs).

On my system, it only has power/button/power device path, whereas on VirtualBox, it has both power/button/power and power/button/sleep.

Change History (2)

comment:1 by jessicah, 5 years ago

Resolution: fixed
Status: newclosed

Was fixed in hrev47736.

comment:2 by mmu_man, 14 months ago

FWIW it's still not working on my old ASUS. It worked again at some point but not long.

Note: See TracTickets for help on using tickets.