Opened 5 years ago

Closed 5 years ago

#11076 closed bug (fixed)

building haiku on haiku: "package cmake not available!", "don't know how to make <x86>crtbeginS.o"

Reported by: taos Owned by: zooey
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm using hrev47579 gcc2 hybrid (upgraded via pkgman from hrev47567).

When starting to build hrev47579 gcc2 hybrid (jam -q @release-raw) I get the following message:

...
Starting build of type regular ... 
Building Haiku R1/development preview 
AddHaikuImagePackages: package llvm not available! 
WebKit build feature not available for x86_gcc2 
Gutenprint support not available on x86 
qrencode support not available on x86 
AddHaikuImagePackages: package cmake not available! 
...patience...
don't know how to make <x86_gcc2>crtbeginS.o
don't know how to make <x86_gcc2>crtendS.o
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
don't know how to make <x86>crtbeginS.o
don't know how to make <x86>crtendS.o
...found 113930 target(s)...
...updating 4268 target(s)...
...can't find 4 target(s)...
...can't make 1868 target(s)...
...

And at the end:

...
...skipped 1868 target(s)...
...updated 4023 target(s)...

Is this related to changes in hrev47577? I didn't get these warnings when building hrev47569 on hrev47567.

Change History (5)

comment:1 Changed 5 years ago by zooey

Owner: changed from bonefish to zooey
Status: newin-progress

comment:2 Changed 5 years ago by zooey

Resolution: fixed
Status: in-progressclosed

Yep, that build failure was indeed caused by hrev47577 - thanks for the heads up.

Should be fixed again in hrev47580.

comment:3 Changed 5 years ago by X512

Resolution: fixed
Status: closedreopened

Build of hrev48213 fails on hrev48192. Build log:

> jam -q @nightly-raw -j2
Starting build of type regular ... 
Building Haiku Nightly 
WebKit build feature not available for x86_gcc2 
Gutenprint support not available on x86 
qrencode support not available on x86 
AddHaikuImagePackages: package cmake not available! 
don't know how to make @nightly-raw
...patience...
don't know how to make -j2
...found 2 target(s)...
...can't find 2 target(s)...
> cmake --version
cmake version 3.0.0

CMake suite maintained and supported by Kitware (kitware.com/cmake).
Last edited 5 years ago by X512 (previous) (diff)

comment:4 Changed 5 years ago by X512

Sorry, it seems that I placed jam arguments in wrong order. "jam -j2 -q @nightly-raw" is working. Ticket can be closed.

comment:5 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.