Opened 12 years ago

Closed 12 years ago

#1108 closed bug (fixed)

[ACPI] The system hang when setting ACPI_SYS_MODE_ACPI

Reported by: oco Owned by: korli
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

The system hang when setting ACPI_SYS_MODE_ACPI.

Unfortunately, my laptop does not have any a serial port. I cannot provide any debug output.

With some manual debug messages, i found that the system stop when writing ACPI_SYS_MODE_ACPI to jump into ACPI mode using AcpiOsWritePort. The caller's function is ACPIHWSetMode.

The system is in ACPI mode as the power button act like in this mode (i have to push it many second to stop the computer).

Under BeOS, ACPI is loaded correctly on this computer using an older ACPI module (when it was still compatible with BeOS, aka in late October 2006).

Change History (6)

comment:1 Changed 12 years ago by axeld

Owner: changed from axeld to korli

comment:2 Changed 12 years ago by oco

The problem is fixed in hrev23112.

I don't know who is credited for this fix. Maybe it is related to hrev23100.

This is a good news as i will be able to work again on my powernow! driver under Haiku.

comment:3 Changed 12 years ago by korli

OK, be sure to reopen if it happens again. Are you sure the acpi module was included in your build ?

comment:4 Changed 12 years ago by oco

Yes, the ACPI module is really loaded as i am even able to load my AMD64 driver. And it works (except timing problem) !

Here is what i can read in my Haiku syslog : ... KERN: amd64: init_hardware() KERN: amd64: init_driver() KERN: Found AMD Athlon 64 / Opteron processor supporting p-state transitions KERN: amd64: Asked CPU State (from config file) : 0 KERN: amd64: Asked CPU State (after converting value) : 0 KERN: amd64: Found ROM BIOS area KERN: amd64: found RSDP_SIG at 0x92e1bea0, 0x92e05000, 0x00016ea0 KERN: amd64: 0x1ff792dc KERN: amd64: RSD PTR ...

comment:5 Changed 12 years ago by jackburton

I think you forget to close this one...

comment:6 Changed 12 years ago by korli

Resolution: fixed
Status: newclosed

Closing

Note: See TracTickets for help on using tickets.