Opened 5 years ago

Closed 5 years ago

#11136 closed bug (fixed)

DriveSetup not recognize BFS Particion

Reported by: un_spacyar Owned by: jessicah
Priority: normal Milestone: R1
Component: Partitioning Systems Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I had a BFS formatted partition that is incorrectly recognized as NT File System, and get an I/O Error when try to mount it.

The partition is correctly recognized in hrev45740; but in recent build, (hrev47707) had the problem previously mentioned.

Adittional information: the problematic partition, originally was a NTFS partition, that was re-formated as BFS (not a booteable one), using hrev45740. However, until now, I never had any problem with is.

both systems was gcc2 hybrid.

Attachments (5)

DriveSetup_hrev45740.png (56.3 KB) - added by un_spacyar 5 years ago.
DriveSetup hrev45740
DriveSetup_hrev47707.png (49.6 KB) - added by un_spacyar 5 years ago.
DriveSetup hrev47707
PartitionType_hrev47707.png (59.2 KB) - added by un_spacyar 5 years ago.
PartitionType_hrev45740.png (66.7 KB) - added by un_spacyar 5 years ago.
DiskProbe.png (50.6 KB) - added by un_spacyar 5 years ago.
DiskProbe

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by un_spacyar

Attachment: DriveSetup_hrev45740.png added

DriveSetup hrev45740

Changed 5 years ago by un_spacyar

Attachment: DriveSetup_hrev47707.png added

DriveSetup hrev47707

comment:1 Changed 5 years ago by un_spacyar

About the screenshots; the problem is in the following partition: dev/disk/ata/0/master/2

Note that in recent build, "Volume name" is blank, and the FileSystem is incorrecty recognized.

comment:2 Changed 5 years ago by anevilyak

1) it would be helpful if you could narrow down when it broke a bit more closely than 2000 revisions. 2) while the partition might contain a BFS filesystem, that doesn't necessarily mean it's correctly tagged as such in the partition table. Please verify that the partition type is correct.

comment:3 Changed 5 years ago by un_spacyar

Hi anevilyak! How I can verify the partition type?

Thank you!

comment:4 Changed 5 years ago by un_spacyar

Sorry about my last comment. I found the "Partition Type" info. In both cases, the partition type is "Be File System".

See new attach.

Changed 5 years ago by un_spacyar

Attachment: PartitionType_hrev47707.png added

Changed 5 years ago by un_spacyar

Attachment: PartitionType_hrev45740.png added

Changed 5 years ago by un_spacyar

Attachment: DiskProbe.png added

DiskProbe

comment:5 in reply to:  4 Changed 5 years ago by un_spacyar

Hello. I open the partition with the "DiskProbe" app, and I see a "NTFS" string in the first sectors of the partition (see new attachment). Maybe this partition had some "inconsistent" state (as I said previously, it was a NTFS partition first, but then reformateed as BFS), that causes the issue.

Maybe this ticket is invalid, after all....

comment:6 Changed 5 years ago by greekboy

I have the same problem, with Installer (DriveSetup) and with the application DriveSetup.

comment:7 Changed 5 years ago by jessicah

Owner: changed from bonefish to jessicah
Status: newassigned

It seems to be a problem with the BFS init code. I had a similar issue just now trying to reformat an NTFS partition to BFS. It said it completed successfully, although the label it presented in the alert was "" instead of the requested name of "Data".

Opening DiskProbe, I too saw the NTFS data in the first sector was still present. And the syslog showed it scanning for partitions and identifying it as NTFS.

My solution was to erase the first sector with DiskProbe (just filling with spaces is sufficient). After doing this, DiskSetup correctly initialised the BFS partition.

However, opening with DiskProbe, I see the first sector is still untouched. This likely explains the issue (seems the BFS superblock is at sector 1, not sector 0).

comment:8 Changed 5 years ago by jessicah

Resolution: fixed
Status: assignedclosed

Fixed in hrev48305.

Note: See TracTickets for help on using tickets.