Opened 5 years ago

Closed 16 months ago

#11161 closed bug (fixed)

Nightly builds no longer recognize my iprowifi2200 wireless card.

Reported by: Tyro65 Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/iprowifi2100 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The last build that worked was 46632. Running install-wifi-firmwares.sh does not install the driver. I've tried to expand ipw2200-fw-3.1.tgz but, alas, it resides in as read-only folder. And I have tried to to copy the files:

ipw2200-bss.fw ipw2200-ibss.fw ipw2200-sniffer.fw

from R1-Alpha4.1 to the /firmware/iprowifi2200/

folder in Haiku 47380 nightly. Of course they cannot be copied to a read-only folder. I have attached a text file with the output of ifconfig and listdev and listimage. I hope this will help correct the problem.

Attachments (1)

TicketFor_iprowifi2200_Bug (55.1 KB ) - added by Tyro65 5 years ago.
Terminal output from ifconfig, listdev and listimage.

Download all attachments as: .zip

Change History (10)

by Tyro65, 5 years ago

Attachment: TicketFor_iprowifi2200_Bug added

Terminal output from ifconfig, listdev and listimage.

comment:1 by anevilyak, 5 years ago

Component: - GeneralDrivers/Network/iprowifi2100

comment:2 by taos, 5 years ago

I'm usually using a laptop equipped with iprowifi2100 and occasionally one with iprowifi2200. Both worked in the latest nightlies >> hrev47380 (47380 is a few months old?) However, there are a few known problems regarding installation of wifi firmwares.

1.) install-wifi-firmwares.sh might need a working network connection to download firmware files even if they are already included in the nightly image which is the case for iprowifi2200 (#10464).

Update: fixed in hrev47749.

2.) Even if the firmware package is activated (expanded firmware files appear in /system/data/firmware/iprowifi2200) you still need to reboot haiku before the corresponding driver works.

3.) Sometimes the activated firmware package is de-activated within seconds (haven't seen this for quite some time) (#10914).

Last edited 5 years ago by taos (previous) (diff)

comment:3 by taos, 5 years ago

Checked with nightly hrev47758 gcc2 hybrid: drivers for iprowifi2100 and iprowifi2200 both work after firmware installation and rebooting.

My iprowifi2200 device has a slightly different device number. From listdev:

device Network controller [2|80|0]
  vendor 8086: Intel Corporation
  device 4223: PRO/Wireless 2915ABG [Calexico2] Network Connection

From listimage:

 1514 0xde853000 0xde8b0000     0          0 /boot/system/add-ons/kernel/drivers/dev/net/iprowifi2200
Last edited 5 years ago by taos (previous) (diff)

comment:4 by luroh, 5 years ago

Tyro65: Please try a recent nightly. If it still doesn't work; I can't find revision 46632 in the old nightly build archive, did you build it yourself? Could you possibly provide a more narrow regression range than 46632-47380?

comment:5 by Tyro65, 5 years ago

I gave up for a while trying to get wifi (ipw2200) working with new builds of Haiku on my old Dell Latitude D600. I've just tried hrev49008. After running install-wifi-firmwares.sh and rebooting, the system freezes about three seconds after the desktop appears. How do I fix this?

Thanks

Stan

comment:6 by pulkomandy, 5 years ago

Without more information it's hard to tell, usually freeze problems are caused by an interrupt conflict leading to interrupts not being routed properly. There are a few things to try to collect more information:

  • Enter the kernel debugger (pres alt+print screen+d) and run the "ints" command to get information about interrupts (in particular looks for a huge number of "unhandled" interrupts, which shows a problem in sending an interrupt to the wrong handler)
  • Try to change the setting of "plug and play OS" and/or or change interrupt assignments in your BIOS to avoid multiple devices using the same interrupt
  • Hold space at boot (before the bootscreen is shown) to get to the early boot menu and try changing some options. Interesting ones are "disable SMP", "disable APIC", maybe a few others.

Let us know the results of these tries.

comment:7 by Tyro65, 5 years ago

Thanks for your help, Pulkomandy,

You're right about quite a few unhandled interrupts. I tried other builds too and getting much the same results with the "ints" command. I tried changing some of the settings in the BIOS, and I tried various boot options to no avail. I have reverted back to hrev47758, upon which I can get wifi working. At least I can play around with Haiku and get better acquainted with this rebuild of BeOS until I acquire a more suitable machine.

comment:8 by Tyro65, 5 years ago

Hey, my wifi is working now, after I installed "Discover Haiku."

comment:9 by waddlesplash, 16 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.