Opened 6 years ago

Closed 17 months ago

Last modified 6 weeks ago

#11177 closed bug (fixed)

Building haiku on haiku leaves reference to the build tree in libraries

Reported by: pulkomandy Owned by: zooey
Priority: normal Milestone: R1/beta2
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

gcc2hybrid, hrev47749.

/system/lib/x86> readelf -aW libnetwork.so |grep libsupc++
 0x00000001 (NEEDED)                     Shared library: [/Donnees/Dev/Haiku/haiku/generated/build_packages/gcc_x86_syslibs-4.8.3_2014_07_26-2-x86_gcc2/lib/x86/libsupc++.so]

This works ok (as long as I don't delete the generated folder...) but I can't build some stuff in HaikuPorter (eg fontconfig_x86) because of it (as my Donnees disk is not available there).

Change History (3)

comment:1 by waddlesplash, 19 months ago

This should be fixed with hrev52467 (and parent commits.)

comment:2 by waddlesplash, 17 months ago

Resolution: fixed
Status: newclosed

Confirmed that it is.

comment:3 by nielx, 6 weeks ago

Milestone: R1R1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.