Opened 5 years ago

Closed 5 years ago

#11191 closed bug (fixed)

New strings don't arrive at pootle site

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone:
Component: Website/Pootle Version:
Keywords: Cc:
Blocked By: Blocking: #11307
Has a Patch: no Platform: All

Description

The pootle site apparently doesn't import new strings from the repo anymore. Some weeks back, the mount settings moved to the Tracker preferences. Since then "Disk mount" hasn't appeared at the pootle site.

Attachments (1)

zipCatKeys.sh (1.6 KB ) - added by mmadia 5 years ago.
script for generating and uploading catkeys

Download all attachments as: .zip

Change History (25)

comment:1 by humdinger, 5 years ago

If it's any help, here's the "Disk mount" string that won't show up at pootle.

comment:2 by korli, 5 years ago

I also don't see strings for the PSDTranslator (added end of August).

comment:3 by mmadia, 5 years ago

Does this coincide with the new buildbot server? When I get back Monday night, I could attach the scripts that were used for packaging and uploading the catkeys

comment:4 by waddlesplash, 5 years ago

Owner: changed from nielx to zooey
Status: newassigned

Indeed it does. Reassigning to Oliver as he set up the buildbot.

comment:5 by nielx, 5 years ago

Sorry to have missed this ticket before, indeed, the buildbots need to export the catkeys somewhere. After adding the scripts, let me know what the new location of the files is and I can update vmdev to pull these new files.

comment:6 by humdinger, 5 years ago

Blocking: 11307 added

by mmadia, 5 years ago

Attachment: zipCatKeys.sh added

script for generating and uploading catkeys

comment:7 by mmadia, 5 years ago

Here is the script that was used. It was run from within my nightly-uploader.sh script.

comment:8 by zooey, 5 years ago

Thanks for the script! I have added something along those lines to the new buildbot instance, it should be running with the next round of nightly builds.

The new target URL is: http://download.haiku-os.org/catalogs/catkeys.zip

Once the upload is indeed working and Niels has adjusted Pootle to the new URL, the strings should be upgraded regularly, again.

comment:9 by diver, 5 years ago

The new target URL doesn't seem to work

in reply to:  9 comment:10 by zooey, 5 years ago

Replying to diver:

The new target URL doesn't seem to work

Sorry about that - permission problems. Should be fixed now.

comment:11 by dsjonny, 5 years ago

I think it is still not working. :( I have checked the Pootle at the moment and there are still no unstranslated / new strings (for Hungarian).

comment:12 by jessicah, 5 years ago

Yes, nielx will need to update his part of the process now (catkeys.zip downloads fine).

comment:13 by nielx, 5 years ago

Getting started on this now.

comment:14 by nielx, 5 years ago

New strings are available now.

comment:15 by diver, 5 years ago

It seems that it only worked once. New strings don't arrive again.

comment:16 by waddlesplash, 5 years ago

I would expect they would only arrive once a week, no? And they most certainly did arrive again -- after Adrien removed some strings from the Notifications preflet, they were deleted in the next "Update strings from pootle" commit.

comment:17 by nielx, 5 years ago

I would say it is working, this morning there was another commit (hrev48250).

comment:18 by taos, 5 years ago

There might still remain a problem with applications that changed their name or location. Before the "new" network preflet became the default one it used to live under /tests/kits/net/preflet (and that's where its strings on pootle currently still seem to reside). Strings in /preferences/network seem to belong to the previous network preflet (the one with a "DNS Servers, comma-separated" entry).

comment:19 by nielx, 5 years ago

So would it be okay to drop the current translations for the network preflet and load the new ones?

comment:20 by pulkomandy, 5 years ago

Yes, the old network preferences is gone, strings can be removed.

Please also drop CDPlayer (it was removed from Haiku).

comment:21 by nielx, 5 years ago

CDPlayer is deleted from Pootle and will be removed from the repository on the next sync (i.e. next week Saturday).

The network preferences need some more investigation. The preflet itself does not seem to generate a catkeys file (it is not in the jamfile). The two add-ons do generate strings, though the ServicesAddon will only really load new strings next week because of hrev48354.

So the only todo is to let the network preflet generate catkeys. I will see if I can add that to the Jamfile now.

comment:22 by pulkomandy, 5 years ago

Not only the Jamfile support is missing: the preflet itself is missing the B_TRANSLATE macros so no data will be collected. I will have a look at doing that.

comment:23 by nielx, 5 years ago

Owner: changed from zooey to pulkomandy

Assigning this to you, this issue is resolved when the network preflet is translatable.

comment:24 by pulkomandy, 5 years ago

Resolution: fixed
Status: assignedclosed

Added that missing DoCatalogs in hrev48424.

Note: See TracTickets for help on using tickets.