Opened 5 years ago

Closed 5 years ago

#11211 closed bug (fixed)

[vmware] video driver cursor inversion

Reported by: diver Owned by:
Priority: normal Milestone: R1
Component: Drivers/Graphics/VMware Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev47828.

I've tried to run Haiku in VMware Fusion 7 on my MacBook Air and noticed that it works much faster and overall snappier than in VirtualBox, host cpu usage is higher tho. When I started BeZilla cursor turned black with white arrow inside - BeZilla cursor for links but inverted. See mozilla/widget/src/beos/nsWindow.cpp and accelerants/vmware/Cursor.c. Cursor remained black even after closing BeZilla.

Change History (3)

comment:1 Changed 5 years ago by diver

Summary: [vmware] video driver cursor invertion[vmware] video driver cursor inversion

comment:2 Changed 5 years ago by axeld

What graphics driver is VMware using? It's likely an effect of the partial hardware cursor support.

comment:3 Changed 5 years ago by diver

Resolution: fixed
Status: newclosed
device Generic system peripheral [8|80|0]
  vendor 15ad: VMware
  device 0740: Virtual Machine Communication Interface
listimage | grep accel
 2520 0x01557000 0x0155a000     0          0 /boot/system/add-ons/accelerants/vmware.accelerant

I can't reproduce it now. Probably fixed in hrev48185.

Note: See TracTickets for help on using tickets.