Opened 4 years ago

Closed 4 months ago

#11309 closed bug (invalid)

atheroswifi: devices not reinitialized after rebooting

Reported by: tidux Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/atheroswifi Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If Haiku shuts down with the Atheros device in the wrong state, it is not detected by Haiku on next startup, or only partially detected with no ability to scan for or connect to networks. This does not happen with Windows 7, GNU/Linux, or OpenBSD, and booting into one of those OSes will reset the device so that it appears on next boot into Haiku. This looks like the driver isn't resetting the device before attempting to use it.

This may actually be a problem with the way Haiku handles PCIe devices in general, since it's a similar pattern to the problems I've had with the onboard Conexant HD Audio on the same machine (Thinkpad x120e), only there the default state is non-working.

Change History (3)

comment:1 Changed 3 years ago by diver

Possibly partially a dupe of #6423.

comment:2 Changed 4 months ago by tidux

I no longer have access to the laptop for which this ticket was reported and so can not confirm a fix.

comment:3 Changed 4 months ago by waddlesplash

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.