Opened 4 years ago

Closed 4 years ago

#11406 closed bug (fixed)

MediaPlayer unable to open any file: "General system error"

Reported by: v.vill Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Greetings, opening any file with MediaPlayer (either from the Tracker or the application's File menu) results in an error window: "file could not be opened -- General system error". Not sure if it's related, but stdout shows " Controller::SetTo: InitCheck failed". (Interestingly, when opening a file from the Tracker, the error message shows up before any MediaPlayer window gets drawn.)

I'm running the latest hrev28210 gcc2 hybrid on bare metal; everything was running smoothly yesterday but now it's inexplicably broken (I've run a pkgman update, but haven't seen any new MediaKit stuff in the list). I have deleted my home/config/settings but to no avail. It looks similar to #8695, but does affect *every* media file (audio or video, local or on external mountpoints).

Change History (5)

comment:1 in reply to:  description Changed 4 years ago by v.vill

Replying to v.vill:

I'm running the latest hrev28210 gcc2 hybrid

I meant hrev48210, obviously...

comment:2 Changed 4 years ago by pulkomandy

Check your /system/package and make sure you don't have an ffmpeg-0.11 package there. This was added to the repos for a short time then removed again. You should have an ffmpeg-0.10.14 package instead.

The ffmpeg_x86 package is at version 0.11 but this is not a problem.

comment:3 Changed 4 years ago by diver

pkgman uni ffmpeg ; pkgman ins ffmpeg should fix it.

comment:4 Changed 4 years ago by v.vill

Thanks, that was indeed the cause. It's fixed now. I'll let you close this one. (I now have a different problem with the media server but I'll open a separate issue.)

comment:5 Changed 4 years ago by diver

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.