Opened 12 years ago

Closed 12 years ago

#1145 closed bug (fixed)

vm_page_fault in "/dev/net/bcm570x/0" driver

Reported by: oco Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Network Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

vm_page_fault: unhandled page fault in kernel space at 0x0, ip 0x0

Networking was working with my prior checkout around revision 20561 (i don't remmeber if it was before or after).

The console debug output stop after those lines (before entering kernel debugging land) : ... initializing module network/stack/socket/v1 (at 0x803e1cc0)... ...done (No error) vm_soft_fault: va 0x0 not covered area in address space vm_pafe_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x0, write 0, user 0, thread 0x34

I can't show the entire stack trace as i can't use serial debugging It look like that : stack trace for thread 0x34 "/dev/net/bcm570x/0" ...<debugger related functions> vm_page_fault i386_handle_trap + 0x00a6 devfs_iocltFPvN20ulT0ul ... syscall_dispatcher i386_handle_trap ... libnetwork.so@0x00492000:unknown + 0xafca ... 532:/dev/net/bcm570x/0_34_stack@0x70000000 + 0x3ffec

Change History (2)

comment:1 by oco, 12 years ago

The problem is fixed in revision 20681. Or maybe it was a build problem on my machine...

comment:2 by korli, 12 years ago

Resolution: fixed
Status: newclosed

Closing. Bug gone ...

Note: See TracTickets for help on using tickets.