Opened 5 years ago

Closed 3 years ago

#11456 closed bug (duplicate)

Failure to boot with Radeon Video Card - nightly regression

Reported by: mvfranz Owned by: kallisti5
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I am able to boot my desktop using R1 Alpha 4.1 from a USB Stick without issue. When trying the latest nightly hrev48257 it fails to boot. It completes the initialization process, but then seem to fail on initializing the video card. The system hangs with a white screen. I can boot in safe video mode.

I tried numerous versions and found that the last version to boot is hrev46791. The following nightly build href46860 fails to boot. I download the nightlies from here http://haiku-files.org/haiku/development/ . Based on the diff from the link, I do not understand why it would start to fail between these versions.

My hardware is: ASUS Sabertooth I7-3770k Radeon HD 7700 Series

I have attached the output from listdev and listimage of hrev46791.

Attachments (7)

listimage.log (53.5 KB) - added by mvfranz 5 years ago.
listdev.log (3.1 KB) - added by mvfranz 5 years ago.
var-log.tar.gz (106.5 KB) - added by mvfranz 5 years ago.
100_2449.JPG (1.5 MB) - added by jstressman 5 years ago.
100_2450.JPG (1.4 MB) - added by jstressman 5 years ago.
listdev-jstressman1.txt (4.5 KB) - added by jstressman 5 years ago.
syslog (328.4 KB) - added by jstressman 5 years ago.
radeon full boot syslog

Change History (17)

Changed 5 years ago by mvfranz

Attachment: listimage.log added

Changed 5 years ago by mvfranz

Attachment: listdev.log added

comment:1 Changed 5 years ago by anevilyak

Component: - GeneralDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5

comment:2 Changed 5 years ago by kallisti5

Likely using vesa before.. this is a very new card. I need to get a new generation Radeon HD 7xxx card for additional 7xxx testing.

Could you grab all of the syslog files in /var/log? If you get a white screen you can press space just before the haiku boot splash to select fallback vesa.

comment:3 Changed 5 years ago by mvfranz

Here is the /var/logs/* from version hrev46860. This is the first version that failed to boot. I have another ASUS board running a Radeon HD 7800 card. The details of the failed start might be in the logs as well (7800 version)- but this system is less supported and not sure it made it as far.

Using space did not bring up the menu, I needed to use 'shift'.

Changed 5 years ago by mvfranz

Attachment: var-log.tar.gz added

comment:4 Changed 5 years ago by jstressman

I'm running into what I think might be the same problem. I'll be attaching listdev and 2 photos of boots where it freezes during the video driver loading.

Using safe mode video lets me boot fine.

This is on build hrev48579 with a radeon 7970.

Changed 5 years ago by jstressman

Attachment: 100_2449.JPG added

Changed 5 years ago by jstressman

Attachment: 100_2450.JPG added

Changed 5 years ago by jstressman

Attachment: listdev-jstressman1.txt added

comment:5 in reply to:  4 Changed 5 years ago by kallisti5

Replying to jstressman:

I'm running into what I think might be the same problem. I'll be attaching listdev and 2 photos of boots where it freezes during the video driver loading.

Using safe mode video lets me boot fine.

This is on build hrev48579 with a radeon 7970.

Any chance of a full syslog? It looks like the DisplayPort link training is failing (all that DP code is extremely young)

comment:6 Changed 5 years ago by jstressman

The problem is that the syslog doesn't get written because the boot stops and I have to reset the machine. If there were a way to make sure the log gets written to disk before reboot, then I could.

This machine doesn't have a serial port, so my cable does me no good on here.

Any ideas?

comment:7 Changed 5 years ago by anevilyak

Assuming you're able to reset the machine without a hard power off, holding down shift at the start of boot to get into the boot loader will include an option to view the previous in memory syslog, and to write it to a fat32 formatted USB stick if you have one.

comment:8 Changed 5 years ago by jstressman

Oddly enough it booted today without selecting safe mode video. No idea why. It wouldn't boot yesterday past this point even after multiple tries.

Anyway, here is the full syslog from today.

Changed 5 years ago by jstressman

Attachment: syslog added

radeon full boot syslog

comment:9 Changed 3 years ago by kallisti5

Duplicate of #8626. radeon_hd needs DisplayPort support still. If you want to use a native DP monitor, try forcing VESA for now if it gives you a native mode. This can be applied via the kernel config file in /boot/home/config/settings

comment:10 Changed 3 years ago by kallisti5

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.