Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11462 closed bug (fixed)

Network Preferences can't disable interfaces

Reported by: vidrep Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Network Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I disable the interface, the interface status tab is still showing as "connected", and the replicant is still showing as "ready". In fact, with the device disabled, I can still connect to the interne (see screenshot1)

Attachments (1)

screenshot1.png (219.2 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by vidrep

Attachment: screenshot1.png added

comment:1 Changed 5 years ago by pulkomandy

Summary: Network Preferences settingsNetwork Preferences can't disable interfaces

comment:2 Changed 4 years ago by axeld

Resolution: fixed
Status: newclosed

Should be fixed in hrev48933. Please be aware that there is a bug in the network stack that easily causes a KDL when disabling/enabling devices.

comment:3 Changed 4 years ago by vidrep

I can disable the interface in the preferences panel now, and confirm that it disconnects. However, when I re-enable the interface, it indicates a connection has been established, but there is not a connection to the internet. I tried using both Web+ and terminal. I have to reboot before it works again. Thankfully, Haiku is fast at restarting.

Last edited 4 years ago by vidrep (previous) (diff)

comment:4 Changed 4 years ago by axeld

The issue is that the default route is lost in the process for some reason. That should be a problem outside of the network preferences, though.

comment:5 Changed 4 years ago by vidrep

Axel, Should I open a new ticket for this issue if it still exists in the latest nightly?

comment:6 Changed 4 years ago by axeld

That one deserves a new ticket, thanks vidrep!

Note: See TracTickets for help on using tickets.