Opened 5 years ago

Closed 4 years ago

#11522 closed bug (fixed)

[GLTeapot] doesn't render anything

Reported by: diver Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/GLTeapot Version: R1/Development
Keywords: Cc: kim1963
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

GLTeapot window stays black after hrev48356 with intel_extreme driver.

Display controller (VGA compatible controller, VGA controller) [3|0|0]

  vendor 8086: Intel Corporation

  device 0116: 2nd Generation Core Processor Family Integrated Graphics Controller

Change History (7)

comment:1 Changed 5 years ago by diver

Cc: kim1963 added
Owner: changed from kallisti5 to pulkomandy
Status: newassigned

comment:2 Changed 5 years ago by kallisti5

reassigning to PulkoMandy. Likely due to the recent vsync change. Odd that is shows up on intel_extreme but works for PulkoMandy. I haven't tested yet.

comment:3 Changed 5 years ago by diver

Description: modified (diff)

comment:4 Changed 5 years ago by pulkomandy

Yes, it works here.

IIRC the intel_extreme driver has a timeout on the wait_for_retrace, so I'm not sure how this can happen even with a non-working driver.

I'll try to test on more machines here and see if I can reproduce.

comment:5 Changed 5 years ago by axeld

Alternatively, we could either drop the demo, or remove the vsync again -- after all, it doesn't really do anything useful if it cannot even be used as a "see how fast I am" demo anymore :-)

comment:6 Changed 5 years ago by pulkomandy

That's cheating. It exposes a bug in our vsync code, which we should fix :)

I don't really care about removing the demo, but the "how fast I am" doubles as a "see how I can use all your CPU power and make your machine heat up just to spin a teapot", which makes the demo not that great. With hardware acceleration it would be more acceptable, and even there, it makes no sense to render more frames than the hardware can display.

A tearing-free teapot at full frame rate, no matter what the system load is, however, makes a more interesting demo of the multitasking features and how the system stays reactive even under heavy load. This is how I use the teapot when demoing haiku, with some videos playing in the background and using the remaining CPU time.

comment:7 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Fixed in hrev48845.

Note: See TracTickets for help on using tickets.