Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11537 closed bug (duplicate)

WebKit 1.4.7 extremely slow

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #11520 Blocking:
Has a Patch: no Platform: All

Description

I have alpha 4.1, x86_gcc2 and x86_64 partitions on a hard drive. Each partition shares the same hardware. The latest WebKit 1.4.7 either cannot connect to the internet (showing "server not found" message) or a painfully slow websurfing experience. Booting into alpha 4.1 or x86_64 which use earlier WebKit versions function normally.

Change History (5)

comment:1 by pulkomandy, 5 years ago

What is "earlier versions"? Is it even slower than 1.4.6 for example?

comment:2 by vidrep, 5 years ago

Earlier versions as in WebKit 1.1 for alpha 4.1 and WebKit 1.4.6 still used in 64 bit builds.

comment:3 by pulkomandy, 5 years ago

1.1 is too old to compare, there has been many changes making things slower, but also rendering pages more correctly. There is indeed work needed to optimize the rendering code and make it faster now that it works.

I'm surprised that it is slower than 1.4.6, however, it should be faster on the drawing side. What exactly do you see? Is it slow to draw pages, or does it takes forever to load pages or just sits there doing nothing? If it's the latter, then this is a duplicate of #11520 and I'll have a fixed version up shortly.

comment:4 by vidrep, 5 years ago

Usually after loading the default home page it takes forever to navigate away to another page. The progress bar starts then does not move. Eventually it will either load the page or give an error "server not found". When pages are rendered they appear OK. WebKit 1.4.6 was working really well for me last week - probably as fast as Web+ has ever been, in fact.

Last edited 5 years ago by vidrep (previous) (diff)

comment:5 by pulkomandy, 5 years ago

Blocked By: 11520 added
Resolution: duplicate
Status: newclosed

Ok, so it is the same as #11520 and I'll have a fix up once it's done building.

Note: See TracTickets for help on using tickets.