Opened 5 years ago

Closed 5 years ago

#11544 closed bug (fixed)

[app_server] crashes after selecting PNGTranslator in Butterfly

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev48408

  • open an image in Butterfly
  • right click it and select Convert menu
  • select PNGTranslator

Attachments (1)

app_server-197-debug-01-12-2014-09-55-06.report (40.1 KB ) - added by diver 5 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 by pulkomandy, 5 years ago

Reproductible, not specifically with the PNG translator, after clicking around several times in the translator list.

comment:2 by korli, 5 years ago

ServerWindow::fCurrentView is probably NULL, which leads to an invalid virtual dispatch table. I noticed there is also a TODO on the ServerWindow::ResyncDrawState() call.

comment:3 by diver, 5 years ago

Resolution: fixed
Status: newclosed

Can't reproduce anymore. I wonder when it was fixed though.

Note: See TracTickets for help on using tickets.