Opened 5 years ago

Closed 12 months ago

#11548 closed bug (duplicate)

Wifi device doesn't list networks (ralinkwifi driver, chipset rt5390, hp pavilion laptop)

Reported by: MrPingouin Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/ralinkwifi Version: R1/Development
Keywords: Cc:
Blocked By: #14668 Blocking:
Has a Patch: no Platform: All

Description

I'm attempting to make Wifi working on my HP Pavilion dv6 laptop (ralink rt5390 chipset).

I'm currently on NightlyBuild hrev48413. If I don't take the precaution to blacklist the ralinkwifi driver at boot, my system freeze on "loading icons" screen and I can't manage to open the KDL.

What I tried is to download a newer firmware (well, I think) : rt2870.bin, and copied it to /system/non-packaged/data/firmware/ralinkwifi/ , and blacklisted all the firmwares in /system/data/firmware/ralinkwifi at boot.

As a result : the system booted without freezing, and I was even able to see the wifi card in the Network Preferences !

When I press the toggle wifi key on the laptop keyboard, there's a reaction on the syslog, so I guess this part is working.

KERN: usb hub 41: port 4: device removed
KERN: usb hub 41: port 4: new device connected

Unfortunately, the card wasn't able to detect any networks. At the same time, the syslog is flooded by those messages, I don't know what it means.

KERN: wlan_control: 9235, 76
KERN: wlan_control: 9235, 15
KERN: wlan_control: 9235, 76
KERN: wlan_control: 9235, 15
KERN: wlan_control: 9235, 76
KERN: wlan_control: 9235, 15
KERN: wlan_control: 9235, 76
KERN: wlan_control: 9235, 15
KERN: wlan_control: 9235, 76

Note : I copied a downloaded version of rt2860.bin into /system/non-packaged/data/firmware/ralinkwifi, and blacklisted all the firmwares in /system/data/firmware/ralinkwifi, and tried to boot. The system froze at loading screen as before all those operations.

To quote umccullough on irc : "I would create a ticket requesting the driver + firmware be updated to match whatever freebsd is currently using"

Change History (3)

comment:1 by diver, 5 years ago

Component: Network & Internet/WirelessDrivers/Network/ralinkwifi
Keywords: wifi ralink removed
Owner: changed from axeld to nobody

comment:2 by korli, 5 years ago

At any rate a syslog would to determine which hardware you are actually testing. I don't think we had positive feedback for this driver since rt2860 inclusion.

The driver is up to date in regard to FreeBSD 9.3. For the firmwares, I had a look at http://www.mediatek.com/en/downloads/ and it seems the latest is version 26, which is currently what we have.

comment:3 by waddlesplash, 12 months ago

Blocked By: 14668 added
Resolution: duplicate
Status: newclosed

#14668 is a duplicate of this ticket, but that one has more information, so closing this one.

Note: See TracTickets for help on using tickets.