Opened 5 years ago

Closed 5 years ago

#11559 closed bug (fixed)

Removed dead code (CID: 1255314)

Reported by: tgkokk Owned by: bonefish
Priority: normal Milestone: R1
Component: File Systems/UserlandFS Version: R1/Development
Keywords: gci2014 Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

In /headers/private/userlandfs/private/Requests.h, according to CID #1255314, there is some dead code. I don't have the original commit history of this file, so I can't check if this was the intended behavior (and it should be moved somewhere else), but it looks like that line should be removed.

Attachments (1)

0001-Removed-dead-code-CID-1255314.patch (1.4 KB) - added by tgkokk 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by tgkokk

Has a Patch: set

comment:2 Changed 5 years ago by umccullough

Looks like the code there was copied from http://cgit.haiku-os.org/haiku/tree/src/tests/add-ons/kernel/file_systems/userlandfs/r5/headers/private/Requests.h

(hint: maybe you can fix it in both places with your patch)

Seems to have probably come from an external source originally, so the dead line of has been there for a long time.

Changed 5 years ago by tgkokk

comment:3 Changed 5 years ago by tgkokk

OK, I have updated the patch.

comment:4 Changed 5 years ago by tgkokk

Keywords: gci2014 added

comment:5 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Applied in hrev48430.

Note: See TracTickets for help on using tickets.