Opened 13 years ago

Closed 11 years ago

#116 closed bug (fixed)

B_DRAW_ON_CHILDREN view flag doesn't work

Reported by: jackburton Owned by: stippi
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver, sil2100@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

The B_DRAW_ON_CHILDREN view flag doesn't do anything.

The BDragger used in Clock uses this flag, but the parent view doesn't draw on top of its children.

See attached screenshot

Attachments (1)

Clock.jpg (4.2 KB) - added by jackburton 13 years ago.
Clock shot with dragger

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by jackburton

Component: KitsServers

comment:2 Changed 13 years ago by jackburton

Owner: changed from bpmagic@… to stippi

Changed 13 years ago by jackburton

Attachment: Clock.jpg added

Clock shot with dragger

comment:3 Changed 13 years ago by sil2100@…

Cc: sil2100@… added

comment:4 Changed 13 years ago by sil2100@…

* Bug 148 has been marked as a duplicate of this bug. *

comment:5 Changed 13 years ago by jackburton

Summary: B_OP_OVER drawing mode might be broken in some casesB_DRAW_ON_CHILDREN view flag doesn't work

comment:6 Changed 13 years ago by jackburton

Looks like Clock's view uses B_DRAW_ON_CHILDREN, might be the real reason for the dragger not being drawn correctly. At least, B_OP_OVER hasn't anything to do with this bug.

comment:7 Changed 13 years ago by diver

Cc: diver added

comment:8 Changed 11 years ago by jackburton

Description: modified (diff)
Platform: All

comment:9 Changed 11 years ago by jackburton

This problem can be seen also in the BSnow demo.

comment:10 Changed 11 years ago by stippi

Resolution: fixed
Status: newclosed

I have not tested this with the Clock app, only with my test application in the app_server test environment, but it should work as of hrev23154.

Note: See TracTickets for help on using tickets.