Opened 4 years ago

Closed 16 months ago

#11630 closed bug (fixed)

Can only boot x86 64 with local apic disabled

Reported by: HAL Owned by: mmlr
Priority: normal Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: boot freeze rocket icon local apic disable Cc: HAL
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Booting the x86 64 bit haiku versions most times freeze at rocket icon or after desktop loads. The only way to stop this is disabling local apic in the boot options.

  1. Boot one of the latest hrev x86_64 haiku either from usb stick or installed to HD.

result: freeze at last progress icon (rocket) or after desktop loads. I was testing in: hrev48510 x86_64

Attachments (2)

syslog with local apic disabled.txt (11.8 KB) - added by HAL 4 years ago.
Syslog with local apic disabled
syslog boot with local apic enabled.txt (96.9 KB) - added by HAL 4 years ago.
Syslog boot with local apic enabled.

Download all attachments as: .zip

Change History (18)

Changed 4 years ago by HAL

Syslog with local apic disabled

comment:1 Changed 4 years ago by HAL

I accidentally uploaded the "syslog local apic disabled" 3 times. I am having trouble with the upload progress bar not moving after it moves a little at the start, so pressing reload to try and make it complete. The last attemp I went away and did something for 1/4 hour, came back and the progress bar had hard moved but the file seems to get uploaded all the same.

comment:2 Changed 4 years ago by HAL

I will upload another syslog with local apic enabled tomorrow.

Changed 4 years ago by HAL

Syslog boot with local apic enabled.

comment:3 Changed 4 years ago by diver

Component: - GeneralSystem/Kernel
Owner: changed from nobody to axeld

Is this only with x86_64?

comment:4 Changed 4 years ago by HAL

Yes, I have test also with GCC4 hybrid, latest versions.

comment:5 Changed 4 years ago by luroh

Milestone: R1Unscheduled

comment:6 Changed 4 years ago by HAL

I have just tested with hrev48679 x86_64 and booted properly to desktop 2 out of 3 times, local apic enabled. Still not fixed but seems better than before.

comment:7 Changed 4 years ago by HAL

I tested hrev48962 gcc2 hybid. It booted no problem with local apic.

comment:8 Changed 4 years ago by diver

Owner: changed from axeld to mmlr
Status: newassigned

comment:9 Changed 4 years ago by mmlr

Not sure what I can contribute here. The syslog looks rather uneventful to me.

Generally disabling local APIC is like making your machine into a < y2k single processor machine. It disables the mechanism that SMP, the IO-APIC and APIC timers are based on, hence they are all implicitly disabled. So while it is interesting that disabling it doesn't trigger it, it doesn't narrow down the cause all that much. You could try disabling the higher level features (SMP and IO-APIC) one by one and see if that already makes it work.

comment:10 Changed 4 years ago by HAL

This bug looks like it might be fixed. I cannot reproduce it with hrev49663 and after update to hrev4994 x86_64.

comment:11 Changed 4 years ago by diver

Resolution: fixed
Status: assignedclosed

Thanks for the update! Closing.

comment:12 Changed 3 years ago by HAL

The bug is back with latest nightly images (last tested hrev50454 x86_64). I'm not sure it was even gone with hrev49663 to hrev49694. More testing might have shown up. It cannot be reproduced at every boot.

Last edited 3 years ago by HAL (previous) (diff)

comment:13 Changed 3 years ago by HAL

This bug needs reopening.

comment:14 Changed 3 years ago by korli

Resolution: fixed
Status: closedreopened

comment:15 Changed 16 months ago by HAL

With hrev51716 x86_64 I can say the bug is definitely gone. I have restarted it many times and cannot see the bug anymore.

comment:16 Changed 16 months ago by waddlesplash

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.