Opened 5 years ago

Closed 20 months ago

#11656 closed bug (no change required)

Haiku image build failed

Reported by: dsjonny Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I tried to build Haiku from the latest source code (freshly updated) under Haiku hrev48462 x86_gcc2. All of the source code compiled (using jam -j4 @nightly-anyboot), but at the end the Haiku image itself cannot create.

I got many times this problem before, so I tried to remove the contents of the download folder, but it looks like not helped.

Please see the attached log.

Before the only way was to update the Haiku to the latest nightly image and run jam again.

Attachments (1)

build.log (14.5 KB) - added by dsjonny 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by dsjonny

Attachment: build.log added

comment:1 Changed 5 years ago by pulkomandy

How did you get the sourcecode? Make sure you have the git tags (they are not available in the github mirror of the sources for example). If you don't have the git tags you need to set the haiku revision manually.

comment:2 Changed 5 years ago by dsjonny

If I first get the source code I use:

git clone git://git.haiku-os.org/haiku

If I update the source code I use:

git pull git://git.haiku-os.org/haiku

And I build the code from the haiku folder with:

jam -j4 @nightly-anyboot

comment:3 Changed 4 years ago by bonefish

A complete build log would help. My guess is that git tags are missing or that HAIKU_REVISION has been defined to an older revision, so that the Haiku packages built appear to be too old for the HaikuPorts packages.

comment:4 Changed 20 months ago by waddlesplash

Any update here?

comment:5 Changed 20 months ago by dsjonny

Actually I am unable to test it. The ticket is old, I think it can be closed.

comment:6 Changed 20 months ago by diver

Resolution: no change required
Status: newclosed
Note: See TracTickets for help on using tickets.