Opened 5 years ago

Closed 5 years ago

#11704 closed bug (duplicate)

Removing USB key without unmounting them

Reported by: gchauvet Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #6683 Blocking:
Has a Patch: no Platform: x86

Description

Hi,

If I remove an USB key without unmounting them, the kernel crash.

Attachments (1)

syslog.log (3.3 KB) - added by gchauvet 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by anevilyak

Priority: criticalnormal

You're going to have to provide a bit more information here. First of all, without a picture of the panic screen, there's pretty much nothing to go off of to even begin to look as to where the problem might lie. Second, what revision of Haiku was this with? What hardware? This works just fine over here, so this would appear to be in some way hardware-specific, but without any information in the ticket, there's pretty much no way to analyze a problem like this. In general, please provide as much information as possible when you encounter an issue, and don't assume that it happens to everybody else because it happens to you.

comment:2 Changed 5 years ago by starsseed

The kernel panics because there is a risk of data loss if all the datas have not been written to the USB disk.

IIRC, for now, this is the expected behavior.

Just type "continue" in kdl (or "co")

Changed 5 years ago by gchauvet

Attachment: syslog.log added

comment:3 Changed 5 years ago by gchauvet

My apologies for the lack of information....

I repoduce this problem only with an USB key with a FAT32 FS.

comment:4 Changed 5 years ago by luroh

Blocked By: 6683 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.