Opened 5 years ago

Closed 5 years ago

#11708 closed bug (fixed)

HaikuDepot stopped working today (2015-01-05) or yesterday

Reported by: luroh Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Gcc2, @nightly and @release profiles tested, hrev48613.

"An error occurred while initializing the package manager: failed to add system packages to system repository"

Attachments (3)

HaikuDepot_error.png (20.0 KB ) - added by luroh 5 years ago.
hrev48613_x86_gcc2_syslog (384.1 KB ) - added by vidrep 5 years ago.
hrev48613_x86_64_syslog (300.9 KB ) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (15)

by luroh, 5 years ago

Attachment: HaikuDepot_error.png added

comment:1 by vidrep, 5 years ago

Same here after updating to hrev48613. However, one difference is that after opening Haiku Depot and attempting a screenshot of the error message the four CPU cores start alternately spiking at 100% and the mouse cursor flashes in sync.

Last edited 5 years ago by vidrep (previous) (diff)

comment:2 by vidrep, 5 years ago

After a reboot, I tried running "pkgman update" from the terminal, which returned an error message "failed to add system packages to system repository: Name not found" A fresh install of hrev48599 and update to hrev48613 produced the same result. I tried Updating 64 bit Haiku to hrev48613 as well, which produced a system that now will not boot beyond the rocket icon. Attached syslog for both builds.

Last edited 5 years ago by vidrep (previous) (diff)

by vidrep, 5 years ago

Attachment: hrev48613_x86_gcc2_syslog added

by vidrep, 5 years ago

Attachment: hrev48613_x86_64_syslog added

comment:3 by ttcoder, 5 years ago

Blocking: 11666 added

(In #11666) Seems #11708 is another symptom of this nightlies & updates build problem

comment:4 by ttcoder, 5 years ago

Just occured to me, after (even "during) updating my 'experiment' desktop to 48613 as well.

  • Tried launching HaikuDepot even before rebooting (but after pkgman update was done), fails with the above message.
  • rebooted without problem
  • HaikuDepot fails likewise after the reboot to the newly-installed update
  • syslog shows nothing out of the ordinary
  • network no longer works (!).. Right-clicking the deskbar replicant shows "rtl81xx" Ready, as usual, but invoking that menu to open the BAlert, all 3 fields are empty (instead of showing IP addresses).
  • running pkgman install *hpkg on the previous install (to revert to it) fails with the same message in terminal.
  • Pe cannot save files, either by dragging to desktop or invoking "save" menu.

Seems this build inconsistency stuff has taken a turn for the worst, i'll be glad when it's located and terminated with extreme prejudice :-)

comment:5 by ttcoder, 5 years ago

Cc: degea@… added

comment:6 by anevilyak, 5 years ago

Blocking: 11666 removed

First of all, given that no one has come forward to say the same revision actually works for them, there is no inconsistency here. Second, considering that the issue which originally prompted creating the "inconsistencies" ticket was shown to be a result of a bug in a translator, and not an actual build problem, I'm hesitant to say that ticket still serves a purpose. At the end of the day, some bugs won't be reproducible for everyone, and that's simply the nature of things due to differences in hardware/environment/usage. Please don't start assuming that every random new problem is the result of some mystical build boogeyman without evidence.

comment:7 by pulkomandy, 5 years ago

I got issues with rtl81xx today as well. Does this get the interface up?:

ifconfig /dev/net/rtl81xx/0 auto-config
ifconfig /dev/net/rtl81xx/0 up

Pe problems could be the RTF translator interfering as it does with StyledEdit, see #11650 (and try blacklisting the translator to see if that helps).

In general, trying to spot the exact revision where each problem started happening would help. It could be http://cgit.haiku-os.org/haiku/commit/?id=62ede2e6a215a2858333453a52cb81d37b80614b which changes BMessage, and could lead to issues everywhere. Or maybe each of these problems is for a different reason, hard to tell without testing which rev broke things.

in reply to:  7 comment:8 by ttcoder, 5 years ago

Replying to pulkomandy:

I got issues with rtl81xx today as well. Does this get the interface up?:

ifconfig /dev/net/rtl81xx/0 auto-config
ifconfig /dev/net/rtl81xx/0 up

Thanks much for this finding, gets me backup in play somewhat. Shall I create a ticket for us and anyone else that might run into this ? Seems like it's not clear what triggers this, and the rtl81xx driver is quite important here..

(developing)

in reply to:  7 comment:9 by TwoFx, 5 years ago

Replying to pulkomandy:

Pe problems could be the RTF translator interfering as it does with StyledEdit, see #11650 (and try blacklisting the translator to see if that helps).

Pe does not use translators when saving. (Or, as far as I know, anywhere else). Saving works fine for me (hrev48613).

comment:10 by ttcoder, 5 years ago

About Pe not saving files.. Wrong symptoms -- now that I've rebooted I see a bunch of files (for each of my attempts) on the desktop. Seems to be some sort of node monitoring problem instead: the Desktop (nor any other Tracker window that I tried) no longer shows updates, new files created, by Pe or by copying in terminal ..etc. One has to close the window and re-open it again to see the newly created files.

edit: Looks very much worth creating a new ticket for that one right?

edit2: looks like I owe something of an apology to Rene! Things look much less mysterious/worrying now, more like "plain" bugs..

Last edited 5 years ago by ttcoder (previous) (diff)

comment:11 by pulkomandy, 5 years ago

There's one already: #11709.

comment:12 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev48619.

Note: See TracTickets for help on using tickets.