Opened 5 years ago

Closed 5 years ago

#11731 closed bug (fixed)

[HaikuDepot] contents reading slows down package opening

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev48643.

After introducing of Contents tab opening large packages slowed down considerably. E.g. opening haiku base package takes about 2 second now in VBox pegging CPU at 100%.

Change History (1)

comment:1 Changed 5 years ago by stippi

Resolution: fixed
Status: newclosed

I guess the actual problem was caused by debug output which scaled very badly (O(n*n)). But I went ahead and implemented asynchronous populating of the list view in hrev48657. Should be completely eliminated.

Note: See TracTickets for help on using tickets.