Opened 5 years ago

Closed 3 months ago

#11738 closed bug (no change required)

Can't modify tickets any more

Reported by: ttcoder Owned by: haiku-web
Priority: normal Milestone:
Component: Website/Trac Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

First thought it was a Web+ bug, but now I'm trying in Win7 and it does not work either, so it might be Trac itself. Anyway, in both cases, when clicking "Modify ticket" I just get a single radio button ("leave opened") instead of the full form to edit ticket properties.

Attachments (1)

comment_and_leave_new-no-Cc.png (110.5 KB) - added by ttcoder 4 years ago.
I can comment, attach files, leave-as-new, but not CC or un-CC

Download all attachments as: .zip

Change History (18)

comment:1 Changed 5 years ago by ttcoder

Tried cycling my router/box in case it was a case of a blacklisted IP address or whatever, but no change, "Modify ticket" only ever lists "leave as new". No one else seeing this ?

comment:2 Changed 5 years ago by diver

Seems to work, but maybe because I have admin rights here...

comment:3 Changed 5 years ago by taos

I don't have admin rights and I can only choose "leave as assigned/new/...", too (Firefox on linux).

Until last month, I think I could at least change component, version, summary, etc of tickets that I had reported.

comment:4 Changed 5 years ago by richienyhus

I thought someone had changed the permissions to be more conservative, but now I can't even change tickets I have opened, which makes it look like a unintentional change.

(Edit: Seems like I am still given the option of reopening closed tickets.)

Last edited 5 years ago by richienyhus (previous) (diff)

comment:5 in reply to:  4 Changed 5 years ago by anevilyak

Replying to richienyhus:

I thought someone had changed the permissions to be more conservative, but now I can't even change tickets I have opened, which makes it look like a unintentional change.

That was indeed the intention, since the previous configuration essentially allows any random person to create an account and freely modify all tickets in the system ; unfortunately, Trac's permissions aren't that granular, so it's all-or-nothing there it seems.

comment:6 Changed 5 years ago by pulkomandy

The action groups (for tickets) are TICKET_CREATE, TICKET_APPEND, TICKET_MODIFY, TICKET_ADMIN, TICKET_CHGPROP, TICKET_EDIT_CC, TICKET_EDIT_COMMENT, TICKET_EDIT_DESCRIPTION, and TICKET_BATCH_MODIFY. We currently are using only CREATE, APPEND, MODIFY, ADMIN in our permissions setup.

If you think you should have TICKET_MODIFY permissions, kindly request one of the trac admins to add it for you. The admins are: anevilyak, axeld, bonefish, mmadia, nielx, pulkomandy, umccullough, zooey.

We could add at least TICKET_EDIT_CC to logged-in users? (I know some people use this to "subscribe" to tickets and get mail notifications). The one that allowed editing tickets is TICKET_CHGPROP, but it does not seem a good idea to allow this for any logged in user. So I'm going to leave things in this opt-in mode for now.

comment:7 Changed 5 years ago by nielx

The Trac software has not been touched for a while, so it is not a software update issue. There also is no way of giving reporters extra permissions (pulkomandy in comment:6 lists all permissions).

I would consider this ticket to being invalid.

comment:8 Changed 5 years ago by bbjimmy

Not allowing users to follow ticket progress (cc) may deprive devs of valuable information about problems with Haiku. The Trac system is a communications tool, using the capatcha should be all the security needed to protect that communication. Closing this ticket as not valid is not listening to the Haiku testers and users who use the Trac system to deliver information to the devs.

comment:9 Changed 5 years ago by ttcoder

If the haiku team have reason to think there is a possible threat of vandalism (somebody defacing properties on a large scale, creating a nightmare to revert the changes by hand or even requiring a database restore or something), then that justifies tightening the screws security wise, guess that's something we non-admins will have to live with.

After all there are plan Bs for each use-cases for people who are not eligible for extra editing privileges, or don't bother to ask for it:

  • use case: somebody's getting crazy receiving Cc'ed emails and not being able to remove himself from the Cc list: one can always get in touch with the admins (preferably off ticket!), asking one of the 8 admins to unsub him.
  • use case: somebody needs to change a bunch of properties in a ticket, and asks an admin to do so: it's possible to copy-paste the widget labels, then the new value.. based on a temporarily create "new ticket" (since you have no way to materialize the various combo boxes listing, list of components ..etc since now "new ticket" is the only interface where they are visible)..
  • in the more extreme case, one can create a new ticket, with the updated properties, copy-paste the description from the old one, and ask/wait for an admin to close the old ticket as a duplicate of the newer/updated one.. It's gonna fragment the ticket history though.

We can try it for a while and see it that works out for everyone.. If that works for other projects it can work for us too.. I suppose..

Anyway globally a +0 from me but maybe I should shut up if I'm one of those who spammed the db and contributed to the tighenintg of the screws *g*

comment:10 in reply to:  8 Changed 5 years ago by waddlesplash

Replying to bbjimmy:

Not allowing users to follow ticket progress (cc) may deprive devs of valuable information about problems with Haiku.

Actually, if you registered your email address with Trac, any tickets you comment you'll automatically subscribe to, there's no need to add yourself as a CC. (Or at least my account did this until I subscribed to the haiku-bugs@ list).

comment:11 Changed 5 years ago by pulkomandy

Yes, commenting on a ticket is enough to get subscribed to it.

In the past few months we got several people starting to move tickets to different milestones or closing them. Not as vandalism, but trying to help. However the result is mostly everyone trying to move their personal list of "most annoying ticket" to beta1, and this makes it hard to triage things efficiently.

The developers with commit access still can edit tickets, so if you think a ticket should have a different milestone/component/priority, just add a comment to the ticket explaining why you think it should be changed, and a developer will do it or explain you why he won't do it.

And if you are a long-time user/tester/lurker and think you deserve ticket edit permissions, as I said, just ask one of the admins to enable it for your user account. This shouldn't be a problem.

comment:12 Changed 5 years ago by ttcoder

No TICKET_EDIT_CC as of yet, nor response to my email to haiku-os.org; I'm guessing it's a combination of being very busy, or logistical problems with Trac, or something else (but cannot be a triaging concern issue as Trac only allows non-admin users to Cc/Un-Cc their very own address and nobody else's!). Refraining from switching over to straw accounts for now :-)

Last edited 5 years ago by ttcoder (previous) (diff)

comment:13 in reply to:  12 Changed 4 years ago by nielx

Replying to ttcoder:

No TICKET_EDIT_CC as of yet, nor response to my email to haiku-os.org; I'm guessing it's a combination of being very busy, or logistical problems with Trac, or something else (but cannot be a triaging concern issue as Trac only allows non-admin users to Cc/Un-Cc their very own address and nobody else's!). Refraining from switching over to straw accounts for now :-)

TICKET_EDIT_CC is set for all authenticated users, so please attach a screenshot to this ticket to check what is not happening that should be happening.

Changed 4 years ago by ttcoder

I can comment, attach files, leave-as-new, but not CC or un-CC

comment:14 Changed 4 years ago by ttcoder

Thanks so much for looking at this.

It occurs on both current and older hrevs, and in Windows+Opera, so not client-dependant it seems.

Give me a shout if you need more info. This should be easily reproducible by logging in with my creds (assuming they're not hashed on server) and with any non-admin account I guess, unless there's something special about mine..

comment:15 Changed 4 years ago by ttcoder

ping

Any progress on allowing Cc for the purpose of maintaining "watch lists" ?

The hrev48946 fallout is another example of this. It would take me a very short time to cross-post in the relevant tickets if I had been able to add them to my "query" (can post the URL for my query for illustrative purposes if needed though anybody can create one in a couple clicks really), but instead I have to review huge all-encompassing queries and re-read the comments I posted with various cross-references.. Because CC became "verboten" inbetween the opening of initial tickets and today's fix so I can't be 100% certain that my old query (which, as I said, I'm unable to maintain these days so it's been "frozen" for quite some time) has all the relevant tickets in it.. Been at it for 2 hours already.. Not complaining, just sayin' :-)

Any info appreciated :-)

comment:16 Changed 4 years ago by ttcoder

ping

Got an email from umccullough a couple weeks back saying he had just read my email (so everyone don't give up on contact@haiku just yet, that email address does work eventually ;-) , so Cc could get fixed eventually I guess..

(Edit: I did eventually get Cc editing privileges, a couple weeks ago *g*, thanks waddlesplash) (quotting from him, in case it's useful to others: The "haiku-sysadmin" list is the proper place to contact us about those things)

Last edited 7 months ago by ttcoder (previous) (diff)

comment:17 Changed 3 months ago by waddlesplash

Resolution: no change required
Status: newclosed

I think the permissions as-is are fine now; we've granted a few trusted community members the powers to modify tickets as needed.

Note: See TracTickets for help on using tickets.