Opened 5 years ago

Closed 11 months ago

Last modified 11 months ago

#11757 closed bug (fixed)

regression: emails are only partially downloaded, fetching bodies doesn't work

Reported by: taos Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/mail_daemon Version: R1/Development
Keywords: Cc:
Blocked By: #7287 Blocking:
Has a Patch: no Platform: All

Description

I'm on hrev48680 at the moment.

Since a few days (between 12th and 15th), mails are no longer completely downloaded. New mails are identified as "Partially downloaded E-mail". If I try to open one of them, Mail application starts up, mail_daemon tries to fetch the bodies, nothing happens, attribute of mail file is changed to Read, and Mail closes.

This happens on both gcc2hybrid and x86_64.

Change History (15)

comment:1 by pulkomandy, 5 years ago

Blocked By: 7287 added
Resolution: duplicate
Status: newclosed

comment:2 by taos, 5 years ago

Resolution: duplicate
Status: closedreopened

It's not exactly the same problem as mentioned in #7287. The download of a complete mail is never triggered for me. I received my last complete email that can be opened in Haiku more than five weeks ago (I never noticed that this bug was closed because I can no longer receive complete emails). Do I have to delete all my account settings so that downloading complete mails works again?

comment:3 by taos, 5 years ago

I've completely deleted ~/config/settings/Mail and all downloaded mails and created new account settings (via E-mail preferences). However, I still can only get partially downloaded mails. Additionally, I can't use SSL anymore to download mails, I have to choose "No encryption" for connection type (on another system with old account settings SSL still works).

comment:4 by jua, 5 years ago

Are you using POP3 for fetching mails? If yes, the mail fetching should be fixed now with hrev48844.

comment:5 by taos, 5 years ago

Yes, I'm using pop3. I've checked this morning with hrev48848 x86_64. It seems that already partially downloaded mails are still not downloaded completely (but this might be due to my new account settings - it didn't fetch new mails either). After work, I'll revert to my old account settings, remove all downloaded mails and try again. I'll also check on my gcc2 hybrid systems if completely downloading mails that were previously only downloaded partially works now. Thanks for looking into this problem!

comment:6 by taos, 5 years ago

Using hrev48848 gcc2 hybrid and hrev48849 x86_64:

  • New mails are now again downloaded completely.
    • -> Regression seems to be fixed (at least for me).
  • Old mails that have been downloaded partially due to the described bug (don't know if it's the same for intentionally partially downloaded mails because I've never used this option) can't be opened in Mail application (Mail opens an empty window and closes it immediately), their bodies are never fetched.
    • -> This looks similar to #7287 (however, I can't tell if fetching the bodies of partially dowloaded mails actually used to work at the time of that bug report).

comment:7 by axeld, 5 years ago

Downloading partially mails was broken when I started working on the mail stuff, and I'm afraid, it still is. I don't remember the exact state of things, though.

comment:8 by axeld, 4 years ago

Should work again, please retry with a current nightly.

comment:9 by taos, 4 years ago

Sorry, fetching bodies of partially downloaded mails still doesn't work. I'm on gcc2 hybrid hrev50040. If Mail application tries to open them, you see an empty message window flashing for a second, but nothing is downloaded.

comment:10 by taos, 4 years ago

Just updated to hrev50058 x64: fetching downloaded mails might work partially. In the past, I tried to double-click on a partially downloaded mail file in Tracker in order to trigger a complete download (which didn't work) and to read it in Mail application. However, it seems to work when opening a completely downloaded mail in Mail and then go through a bunch of mails via the up/down arrows in the Mail menu bar, so that the body of a partially downloaded mail is fetched and displayed in the mail window (this would probably close #7287). I'll do some further investigations as soon as I receive some new mails that are only partially downloaded.

comment:11 by taos, 4 years ago

Okay, for me, fetching bodies works in hrev50058 x64, but not in hrev50063 gcc2_hybrid. Starting Mail from Terminal with:

Mail ~/mail/in/<name_of_mail_file>

returns the error:

Body could not be fetched. Name not found

Opening mails in this way works on

  • x64 for partially and completely downloaded mails
  • gcc2 hybrid only for completely downloaded mails

comment:12 by waddlesplash, 12 months ago

Still an issue?

comment:13 by taos, 11 months ago

On gcc2 hybrid, I can now fetch the bodies of partially downloaded mails, too.

comment:14 by waddlesplash, 11 months ago

Resolution: fixed
Status: reopenedclosed

Hooray! Thanks for testing.

comment:15 by taos, 11 months ago

At least if the mails were intentionally downloaded only partially. For the mails that were only partially downloaded a few years ago due to the aforementioned bug, the bodies still can't be fetched in the gcc2 hybrid. However, that's not really a problem.

Note: See TracTickets for help on using tickets.