Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11789 closed bug (no change required)

cannot login to my diskstation (homeserver) anymore

Reported by: bruno Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11788
Has a Patch: no Platform: x86

Description (last modified by humdinger)

Since a few months I cannot login to my server anymore... It was working before with some limitations.... I did a clean install still I cannot login... Maybe some adresses are missing? Dont`know!

I will add a screenshot...

English error text

Attachments (2)

screenshot1.png (253.8 KB ) - added by bruno 5 years ago.
synology.png (4.8 KB ) - added by humdinger 5 years ago.
English error text

Download all attachments as: .zip

Change History (15)

by bruno, 5 years ago

Attachment: screenshot1.png added

comment:1 by humdinger, 5 years ago

Attached the English version of that error. BTW, trying to log in with the wrong user name or password is met with the correct message "Account or password is invalid. Try again". So some data makes it back and forth apparently. QupZilla works.

@bruno: FYI, I created this script to mount my NAS via nfs4:

#!/bin/sh

mkdir -p /DiskStation
mount -t nfs4 -p "192.168.178.3:volume1" /DiskStation

by humdinger, 5 years ago

Attachment: synology.png added

English error text

comment:2 by humdinger, 5 years ago

Description: modified (diff)

comment:3 by diver, 5 years ago

Component: Network & InternetApplications/WebPositive
Owner: changed from nobody to pulkomandy

comment:4 by diver, 5 years ago

Blocking: 11788 added

comment:5 by pulkomandy, 5 years ago

You say it was working "before". This is not very helpful for me, as I don't know when the problem was introduced. It would be nice if youcould try older versions of Haiku and/or WebPositive and try to identify which one introduced the problem.

See https://dev.haiku-os.org/wiki/BinarySearch for an efficient way to locate the problem.

comment:6 by humdinger, 5 years ago

I've tried hrev48374 (webkit 1.4.6-3) which doesn't work either. I tried three other old nightlies, but those refuse to boot on my machine (I think I remember there were some issues back then...) Anyway, I can't spend more time on it at the moment. Maybe bruno can remember when it used to work and try a nightly from back then.

Also worth considering: Synology NAS get lots of software updates all the time. Maybe it's not a change in WebKit that's to blame...

comment:7 by axeld, 5 years ago

There is a live demo that may let you reproduce the issue locally: https://www.synology.com/en-us/dsm/live_demo

comment:8 by bruno, 4 years ago

Cannot find the working hrev... now! Sorry!

comment:9 by pulkomandy, 4 years ago

As mentionned by humdinger it could be an update on the NAS Side that makes Web+ fail to connect. So we already had a bug, and their update only makes it visible.

comment:10 by pulkomandy, 4 years ago

Milestone: R1/beta1R1

comment:11 by bruno, 4 years ago

Seems to work now! Maybe a problem on synology Side!?

comment:12 by humdinger, 4 years ago

Resolution: no change required
Status: newclosed

Thanks for the feedback. Re-open the ticket, should the bug re-appear.

comment:13 by bruno, 4 years ago

of course no problem... It works and the file browser is working too... great!

Note: See TracTickets for help on using tickets.