Opened 5 years ago

Closed 5 years ago

#11798 closed bug (duplicate)

WebPositive 64 bit crashes loading page

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #11384 Blocking:
Has a Patch: no Platform: All

Description

Tried to load the following page several times and produced a crash each time.http://www.calgarysun.com/ Debug report attached hrev48730 x86_64 HaikuWebKit 1.4.6 WebKit 601.1.6

Attachments (13)

WebPositive-4172-debug-26-01-2015-18-38-12.report (72.5 KB ) - added by vidrep 5 years ago.
WebPositive-587-debug-27-01-2015-17-57-52.report (80.7 KB ) - added by vidrep 5 years ago.
screenshot2.png (102.9 KB ) - added by vidrep 5 years ago.
screenshot3.png (25.0 KB ) - added by vidrep 5 years ago.
screenshot4.png (160.0 KB ) - added by vidrep 5 years ago.
WebPositive-932-debug-27-01-2015-18-38-48.report (41.7 KB ) - added by vidrep 5 years ago.
WebPositive-1287-debug-28-02-2015-17-59-35.report (82.0 KB ) - added by vidrep 5 years ago.
screenshot1.png (29.5 KB ) - added by vidrep 5 years ago.
screenshot2.2.png (129.2 KB ) - added by vidrep 5 years ago.
WebPositive-788-debug-11-03-2015-17-13-03.report (1.1 KB ) - added by vidrep 5 years ago.
WebPositive-594-debug-11-03-2015-17-21-10.report (1.1 KB ) - added by vidrep 5 years ago.
previous_syslog (178.3 KB ) - added by vidrep 5 years ago.
WebPositive-596-debug-21-02-2015-14-10-49.report (92.9 KB ) - added by vidrep 5 years ago.
32 bit hrev48887 x86_gcc2

Download all attachments as: .zip

Change History (28)

comment:1 by diver, 5 years ago

Platform: Allx86-64

This looks like a dupe of #11384. HaikuWebKit package is outdated on x86_64. Perhaps this is the problem here?

comment:2 by pulkomandy, 5 years ago

Platform: x86-64All

It looks like I closed #11384 too fast as I can reproduce the crash on x86_gcc2 as well with the Calgary Sun website and webkit 1.4.8.

comment:3 by vidrep, 5 years ago

Tried again todayon same webpage using WebKit 1.4.9 on x86_gcc2. Same problem (attached debug report)

Last edited 5 years ago by vidrep (previous) (diff)

comment:4 by vidrep, 5 years ago

While submiting this ticket, Webpositive fails to show text in "Comment" box (screenshot2). When submitting changes only blank page (screenshot3).

by vidrep, 5 years ago

Attachment: screenshot2.png added

by vidrep, 5 years ago

Attachment: screenshot3.png added

comment:5 by vidrep, 5 years ago

This webpage will also cause a crash:http://calgaryherald.com/ Attached screenshot and debug report.

by vidrep, 5 years ago

Attachment: screenshot4.png added

comment:6 by vidrep, 5 years ago

These webpages no longer crash Webpositive with latest .Webkit 1.4.10. It is perhaps safe to assume the problem is fixed, and the ticket can be closed.

comment:7 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

comment:8 by vidrep, 5 years ago

Resolution: fixed
Status: closedreopened

Sorry to reopen, as my test was done using x86_gcc2 WebKit. The 64 bit build has not been updated to WebKit 1.4.10 yet, and is still crashing on launch. I will test it once the updated 64 bit WebKit is released.

comment:9 by vidrep, 5 years ago

Today tried to load Calgary Sun website using hrev48842 x86_gcc2. It crashes every time. So, definitely not fixed or only an issue with 64 bit. Attached debug log.

comment:10 by vidrep, 5 years ago

Description should be changed to "WebPositive crashes loading page" to reflect that it not just a 64 bit issue.

comment:11 by korli, 5 years ago

haikuwebkit package updated to 1.4.10 in hrev48884.

comment:12 by vidrep, 5 years ago

Updated hrev48887 x86_64 Tried to load webpage http://www.calgaryherald.com Debugger was triggered Saved report (actually it created two reports at the same time) Webpositive would not close. Eventually I killed it in team monitor. During this time, process controller showing very high cpu and memory loading. Attached debug reports and scdreenshots I was able to reproduce this three times.

by vidrep, 5 years ago

Attachment: screenshot1.png added

by vidrep, 5 years ago

Attachment: screenshot2.2.png added

by vidrep, 5 years ago

Attachment: previous_syslog added

comment:13 by vidrep, 5 years ago

Updated hrev48887 x86_gcc2 as well. 32 bit Webpositive crashes on the same webpage. 32 bit Debug report seems to have more info than 64 bit (attached). Did not observe same CPU and memory problems as on 64 bit.

by vidrep, 5 years ago

32 bit hrev48887 x86_gcc2

comment:14 by korli, 5 years ago

from both x86_64 reports: "Composite blobs are currently unsupported. Please submit a bugreport with the webpage that triggered this."

comment:15 by diver, 5 years ago

Blocked By: 11384 added
Resolution: duplicate
Status: reopenedclosed

Last debug report deserves its own ticket.

Note: See TracTickets for help on using tickets.