Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11838 closed bug (no change required)

regression: Tracker list view sorting order not stored anymore

Reported by: pulkomandy Owned by: waddlesplash
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tracker used to remember the sorting order for each folder in list mode. It doesn't anymore, and revert to reverse alphabetic, which is rather annoying. It should at the very least use forward alphabetic.

Change History (7)

comment:1 Changed 4 years ago by humdinger

This works here with hrev48742.
I did experience the same thing in file dialogs after waddlesplash's merge of the layout aware Tracker. But I don't see this anymore. Unfortunately I can't remember if I did something or removed some settings...

comment:2 Changed 4 years ago by waddlesplash

@PulkoMandy: Do you experience this in file dialogs, or everywhere else too? Because I did find some instances where the file dialog creation was happening in the wrong order, which is also the cause of #11819.

comment:3 Changed 4 years ago by pulkomandy

This is hrev48756 in case it matters. I had this problem on my Music folder in a standard window (it is set to use list mode by default). Now that particular issue seems to be solved (maybe tracker rewrote the attributes for that folder?)

However, everything seems to use list mode now. I think the default was icon mode before. So there is still something wrong with the default attributes in any case.

comment:4 Changed 4 years ago by waddlesplash

I didn't touch mode changing at all, so that doesn't make sense to me. (Ever since I started using Haiku in ~2012 or so, list mode was always the default for me.)

I guess I can poke around a bit more...

comment:5 Changed 4 years ago by waddlesplash

Owner: changed from axeld to waddlesplash
Status: newassigned

comment:6 Changed 4 years ago by jscipione

Resolution: no change required
Status: assignedclosed

List mode was default on Haiku R1/A4 and BeOS R5 and is still the default today.

comment:7 Changed 4 years ago by pulkomandy

This is not what this ticket was about. It is about the sorting order used, which is reverse alphabetic when it shouldn't be.

Note: See TracTickets for help on using tickets.