Opened 12 years ago

Closed 12 years ago

#1188 closed bug (fixed)

Dragging GLTeapot shows artifacts and locks the system.

Reported by: mmadia Owned by: jackburton
Priority: blocker Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Build 20913 on real hardware p3-1.1G, 256M

Take notice of desktop Run GLTeapot demo. click and drag GLTeapot, -refresh issues- GLTeapot will not refresh properly. While dragging, GLT will display the original desktop clipping. note, i do not mean a transparency, but rather a copy. in addition, the desktop will retain partial artifacts of GLT

note #2, continued dragging will virtually prevent input_server (or app_server?)

from getting mouse clicks and keyboard input. both connected via ps/2 ports. USB untested. this might be related to axeld's comment in bug#1152.

Change History (9)

comment:1 by axeld, 12 years ago

Owner: changed from axeld to jackburton

Sounds like a locking problem with a BDirectWindow.

in reply to:  1 ; comment:2 by jackburton, 12 years ago

Replying to axeld:

Sounds like a locking problem with a BDirectWindow.

I somewhat agree, although the problem must be obviously in the app_server, since the mouse pointer doesn't move anymore either. And actually it only happens with GLTeapot and the GLDirectDemo, not with Chart (which also uses a BDirectWindow, although not a GLView).

in reply to:  2 comment:3 by jackburton, 12 years ago

Replying to jackburton:

And actually it only happens with GLTeapot and the GLDirectDemo, not with Chart (which also uses a BDirectWindow, although not a GLView).

Too bad I can't edit comments... happens only with GLTeapot. GLDirectDemo doesn't suffer from this problem.

comment:4 by mmadia, 12 years ago

build hrev21095 doesn't have the artifacts issue.

however, note #2 still persists.

in reply to:  4 comment:5 by jackburton, 12 years ago

Replying to mmadia:

build hrev21095 doesn't have the artifacts issue.

Yes. Although I had to set the view color to black instead of B_TRANSPARENT_32_BIT, and this clashes with what the bebook says. Maybe we'll want to find a better fix.

comment:6 by jackburton, 12 years ago

Priority: normalblocker
Summary: GLTeapot , drag, artifacts.Dragging GLTeapot shows artifacts and locks the system.

comment:7 by korli, 12 years ago

It doesn't help but the system lock is even more visible with the updated mesa 6.5.3.

comment:8 by kkaloine, 12 years ago

I couldn't see any artifacts and/or locking in the system while trying to reproduce this bug. Tested with Vmware Player and hrev21712.

comment:9 by jackburton, 12 years ago

Resolution: fixed
Status: newclosed

I can't reproduce either. Probably fixed in mesa.

Note: See TracTickets for help on using tickets.