Opened 4 years ago

Closed 2 years ago

#11880 closed bug (fixed)

Web+ redirection doesn't always clear redirect page contents

Reported by: AlienSoldier Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #11954, #12014
Has a Patch: no Platform: All

Description

I think it is redirect related but i could be wrong.

i have a site that i work with saying "object have moved here", on the top of the page (the page is normal other than that top addition. When i click it i then get a normal page without the top message (and it is then an https page).

Someting similat happen with www.goodsearch.com The message i get this time is: "301 Moved Permanently nginx/1.4.7" No clickable link in that case. When i click the login link, the page is now normal without the top message. hrev48839

Attachments (2)

screenshot1.png (299.8 KB) - added by vidrep 3 years ago.
screenshot2.png (27.8 KB) - added by vidrep 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 4 years ago by pulkomandy

Yes, there is a bug with redirects, the data from the redirected request should be ignored, but sometimes it isn't. The problem is I never get this in HaikuLauncher, it only happens with Web+. I don't understand why.

comment:2 Changed 4 years ago by luroh

Blocking: 12014 added

comment:3 Changed 4 years ago by diver

Blocking: 11954 added

comment:4 Changed 4 years ago by pulkomandy

Summary: Web+ redirectionWeb+ redirection doesn't always clear redirect page contents

comment:5 Changed 3 years ago by vidrep

I'm seeing something similar on the Haiku IRC logs. -> Haiku Community Links ->IRC Channels ->Main IRC channel (English)->Channel logs 301 Moved Permanently (screenshot1.png) ->Select any other date 404 Not Found (screenshot2.png)

Changed 3 years ago by vidrep

Attachment: screenshot1.png added

Changed 3 years ago by vidrep

Attachment: screenshot2.png added

comment:6 Changed 2 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Fixed in hrev50917.

Note: See TracTickets for help on using tickets.