Opened 4 years ago

Closed 4 years ago

#11895 closed bug (fixed)

top is broken

Reported by: axeld Owned by: nobody
Priority: normal Milestone: R1/beta1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The "top" command only prints something along these lines nowadays:

  THID   TOTAL    USER  KERNEL %CPU        TEAM NAME THREAD NAME      
------    0.00    0.00    0.00  0.0% TOTAL (11.8% idle time, 88.2% unknown)

Not sure since when this happens; I thought it was the result of outsourcing it, but I just checked, and it's still the version in our repository.

Change History (9)

comment:1 Changed 4 years ago by jscipione

top works for me here on hrev48863

comment:2 Changed 4 years ago by kallisti5

strange... works ok here for me as well:

~> uname -a
Haiku kallbuild01 1 hrev48858 Mar  4 2015 00:31:05 x86_64 x86_64 Haiku
  THID   TOTAL    USER  KERNEL %CPU        TEAM NAME THREAD NAME      
   764    8.53    7.00    0.00  0.0          Deskbar w>Deskbar 
   785    3.00    1.00    1.00  0.0 media_addon_serv HD Audio control 
   787    2.70    1.00    1.00  0.0 media_addon_serv multi_audio audio output 
   788    1.88    0.00    1.00  0.0 media_addon_serv Yeah baby, very shagadelic 
   640    1.36    0.00    0.00  0.0        registrar timer_thread 
   672    1.16    0.00    1.00  0.0      kernel_team ethernet link state checker 
   662    1.14    0.00    1.00  0.0      kernel_team fbsd callout 
   753    0.94    0.00    0.00  0.0       app_server w:704:Deskbar 
    11    0.82    0.00    0.00  0.0      kernel_team page daemon 
     9    0.62    0.00    0.00  0.0      kernel_team page scrubber 
  4086    0.38    0.00    0.00  0.0              top top 
   777    0.30    0.00    0.00  0.0 media_addon_serv Audio Mixer control 
   760    0.30    0.00    0.00  0.0          Deskbar Expando Window Watcher 
   639    0.28    0.00    0.00  0.0        registrar message deliverer 
     6    0.27    0.00    0.00  0.0      kernel_team kernel daemon 
     7    0.21    0.00    0.00  0.0      kernel_team resource resizer 
  4045    0.18    0.00    0.00  0.0       sshd -D -R sshd 
   755    0.17    0.00    0.00  0.0          Tracker w>Desktop 
   664    0.17    0.00    0.00  0.0      kernel_team re intr handler 
   687    0.17    0.00    0.00  0.0     input_server AddOnMonitor 
   637    0.16    0.00    0.00  0.0        registrar _roster_thread_ 
   595    0.15    0.00    0.00  0.0      kernel_team media checker 
   735    0.13    0.00    0.00  0.0     media_server media_server control 
   703    0.12    0.00    0.00  0.0          Tracker Tracker 
   673    0.10    0.00    0.00  0.0      kernel_team /dev/net/rtl81xx/0 reader 
   609    0.09    0.00    0.00  0.0      kernel_team scsi_bus_service 
   734    0.09    0.00    0.00  0.0     media_server big brother is watching you 
   737    0.08    0.00    0.00  0.0 media_addon_serv media_addon_server 
   670    0.08    0.00    0.00  0.0      kernel_team /dev/net/rtl81xx/0 consumer 
   759    0.07    0.00    0.00  0.0          Tracker w>Tracker status 
   768    0.07    0.00    0.00  0.0          Tracker TrackerTaskLoop 
   745    0.05    0.00    0.00  0.0     media_server _BMediaRoster_ 
   772    0.05    0.00    0.00  0.0          Deskbar _BMediaRoster_ 
   740    0.03    0.00    0.00  0.0 media_addon_serv _BMediaRoster_ 
    17    0.02    0.00    0.00  0.0      kernel_team block notifier/writer 
    13    0.01    0.00    0.00  0.0      kernel_team low resource manager 
    10    0.01    0.00    0.00  0.0      kernel_team page writer 
   660    0.01    0.00    0.00  0.0      kernel_team net timer 
   616    0.01    0.00    0.00  0.0      kernel_team syslog sender 
------   25.00   14.00   11.00  0.1% TOTAL (99.8% idle time,  0.0% unknown)

Axel, what hrev, arch, etc?

comment:3 Changed 4 years ago by axeld

On various systems, and revisions, all x86_gcc2. I can still reproduce it here with hrev48882, and, just updated, also with hrev48917.

comment:4 Changed 4 years ago by kallisti5

Haiku kallbuild01 1 hrev48917 Mar 19 2015 04:54:55 x86_64 x86_64 Haiku

Hm.. Maybe limited to x86_gcc2?

  THID   TOTAL    USER  KERNEL %CPU        TEAM NAME THREAD NAME      
   788    0.29    0.00    0.00  0.0 media_addon_serv HD Audio control 
   790    0.25    0.00    0.00  0.0 media_addon_serv multi_audio audio output 
   662    0.24    0.00    0.00  0.0      kernel_team fbsd callout 
    11    0.22    0.00    0.00  0.0      kernel_team page daemon 
   640    0.22    0.00    0.00  0.0        registrar timer_thread 
   669    0.21    0.00    0.00  0.0      kernel_team ethernet link state checker 
   791    0.19    0.00    0.00  0.0 media_addon_serv Yeah baby, very shagadelic 
   835    0.15    0.00    0.00  0.0              top top 
   758    0.09    0.00    0.00  0.0       app_server w:703:Deskbar 
   767    0.07    0.00    0.00  0.0          Deskbar w>Deskbar 
     9    0.07    0.00    0.00  0.0      kernel_team page scrubber 
   664    0.04    0.00    0.00  0.0      kernel_team re intr handler 
   637    0.03    0.00    0.00  0.0        registrar _roster_thread_ 
   639    0.03    0.00    0.00  0.0        registrar message deliverer 
     6    0.03    0.00    0.00  0.0      kernel_team kernel daemon 
     7    0.03    0.00    0.00  0.0      kernel_team resource resizer 
   668    0.02    0.00    0.00  0.0      kernel_team /dev/net/rtl81xx/0 consumer 
   763    0.02    0.00    0.00  0.0          Deskbar Expando Window Watcher 
   685    0.02    0.00    0.00  0.0     input_server AddOnMonitor 
   670    0.02    0.00    0.00  0.0      kernel_team /dev/net/rtl81xx/0 reader 
   756    0.02    0.00    0.00  0.0          Tracker w>Desktop 
   738    0.02    0.00    0.00  0.0         dstcheck w>timedAlert 
   762    0.01    0.00    0.00  0.0          Tracker w>Tracker status 
   771    0.01    0.00    0.00  0.0          Tracker TrackerTaskLoop 
   660    0.00    0.00    0.00  0.0      kernel_team net timer 
------    2.00    0.00    1.00  0.1% TOTAL (95.9% idle time,  4.0% unknown)

comment:5 Changed 4 years ago by pulkomandy

Getting the same bug here (x86_gcc2, hrev48893). On my system with 2 cpu cores:

  THID   TOTAL    USER  KERNEL %CPU        TEAM NAME THREAD NAME      
------    0.00    0.00    0.00  0.0% TOTAL (47.2% idle time, 52.8% unknown)

It seems top only sees one idle thread and nothing else?

comment:6 Changed 4 years ago by anevilyak

There seems to be something hardware and/or configuration-specific to this one ; it's not reproducible with either compiler on my i7 here.

comment:7 Changed 4 years ago by pulkomandy

In case that's relevant then:

~> sysinfo
Kernel name: kernel_x86 built on: Mar 12 2015 20:39:43 version 0x1
2 Intel Core 2, revision 1067a running at 2394MHz

CPU #0: "Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz"
        Raw CPUID: 0x01067a,    Type 0, family 6, model 23, stepping 10, features 0xbfebfbff
                FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT
                PSE36 CFLUSH DS ACPI MMX FXSTR SSE SSE2 SS HTT TM PBE
        Extended Intel: 0x0408e3fd
                SSE3 DTES64 MONITOR DS-CPL VMX SMX EST TM2 SSSE3 CX16 xTPR PDCM SSE4.1 XSAVE
        Extended AMD: type 0, family 0, model 0, stepping 0, features 0x20100000
                NX 64
        Power Management Features:

        L2 Data cache fully associative, 1 lines/tag, 64 bytes/line
        L2 cache: 0 KB, 1-way set associative, 0 lines/tag, 63 bytes/line

        Inst TLB: 2M-bytes pages, 4-way set associative, 8 entries OR 4M, 4-way, 4 entries
        Inst TLB: 4K-bytes pages, 4-way set associative, 128 entries
        Data TLB: 4M-byte pages, 4-way set associative, 32 entries
        64-byte Prefetching
        L1 Data TLB: 4K-bytes pages, 4-way set associative, 16 entries
        L1 Data TLB: 4M-bytes pages, 4-way set associative, 16 entries
        L2 cache: 3072 KB, 12-way set associative, 64 bytes/line, unified on-die
        L1 inst cache: 32 KB, 8-way set associative, 64 bytes/line
        Data TLB: 4K-bytes pages, 4-way set associative, 256 entries
        L1 data cache: 32 KB, 8-way set associative, 64 bytes/line

CPU #1: "Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz"
        Raw CPUID: 0x01067a,    Type 0, family 6, model 23, stepping 10, features 0xbfebfbff
                FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT
                PSE36 CFLUSH DS ACPI MMX FXSTR SSE SSE2 SS HTT TM PBE
        Extended Intel: 0x0408e3fd
                SSE3 DTES64 MONITOR DS-CPL VMX SMX EST TM2 SSSE3 CX16 xTPR PDCM SSE4.1 XSAVE
        Extended AMD: type 0, family 0, model 0, stepping 0, features 0x20100000
                NX 64
        Power Management Features:

        L2 Data cache fully associative, 1 lines/tag, 64 bytes/line
        L2 cache: 0 KB, 1-way set associative, 0 lines/tag, 63 bytes/line

        Inst TLB: 2M-bytes pages, 4-way set associative, 8 entries OR 4M, 4-way, 4 entries
        Inst TLB: 4K-bytes pages, 4-way set associative, 128 entries
        Data TLB: 4M-byte pages, 4-way set associative, 32 entries
        64-byte Prefetching
        L1 Data TLB: 4K-bytes pages, 4-way set associative, 16 entries
        L1 Data TLB: 4M-bytes pages, 4-way set associative, 16 entries
        L2 cache: 3072 KB, 12-way set associative, 64 bytes/line, unified on-die
        L1 inst cache: 32 KB, 8-way set associative, 64 bytes/line
        Data TLB: 4K-bytes pages, 4-way set associative, 256 entries
        L1 data cache: 32 KB, 8-way set associative, 64 bytes/line

7825723392 bytes free      (used/max  652439552 / 8478162944)
                           (cached    477990912)
     63689 semaphores free (used/max       1847 /      65536)
      3840 ports free      (used/max        256 /       4096)
      3860 threads free    (used/max        236 /       4096)
      2017 teams free      (used/max         31 /       2048)

comment:8 Changed 4 years ago by pulkomandy

Does hrev49284 fix this?

comment:9 Changed 4 years ago by axeld

Resolution: fixed
Status: newclosed

Looks like you fixed it indeed, thanks!

Note: See TracTickets for help on using tickets.