Opened 4 years ago

Last modified 7 weeks ago

#11907 new bug

Radeon HD3470 display problem after connecting external display

Reported by: lalit Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: #8612 Blocking:
Has a Patch: no Platform: All

Description

I am using VAIO VGN-FW11E. In hrev48899 after connecting the external display on vga port the laptop display hangs and turn white gradually. Find the attached picture. After disconnecting the external display the main display was displaying normally before. Now the main display is hanging and turning white even after disconnecting the external display. I can use only the external displays now. Before connecting the external display the main display was alright.

Attachments (2)

IMG_2051.JPG (1.8 MB) - added by lalit 4 years ago.
Laptop Screen
syslog (329.1 KB) - added by lalit 4 years ago.
syslog

Change History (6)

Changed 4 years ago by lalit

Attachment: IMG_2051.JPG added

Laptop Screen

Changed 4 years ago by lalit

Attachment: syslog added

syslog

comment:1 Changed 4 years ago by anevilyak

Component: - GeneralDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5

comment:2 Changed 4 years ago by kallisti5

Blocked By: 8612 added

Likely due to lack of multi-monitor support. You plugged the external monitor in and got a mode-line not matching your laptops. Once you unplugged it Haiku continued to use the external mode-line on the LCD.

Blocked by #8612.

To solve:

  • Bring up boot menu (press space a bunch just before the splash)
  • Set video safe mode.
  • Erase this file: /boot/home/config/settings/Screen_data
  • Reboot.

comment:3 Changed 4 years ago by lalit

No difference after deleting the file. Still white screen.

comment:4 Changed 7 weeks ago by lalit

This problem still there in Beta version.

Note: See TracTickets for help on using tickets.