Opened 4 years ago

Closed 2 months ago

#11920 closed bug (fixed)

PANIC: Unexpected exception "General Protection Exception" occurred in kernel mode!

Reported by: darfo Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet Version: R1/Development
Keywords: atheroswifi Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description (last modified by diver)

KDL appears when booting x86_64 hrev48926 on real hardware, Toshiba C640 laptop with 2 core Celeron Wifi is is Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Attached is KDL and ints

System start getting real hot even though fan is running max. System shuts self off after about 20secs.

The real KDL <blush> The real ints </blush>

Attachments (10)

KDL.png (901.6 KB) - added by darfo 4 years ago.
KDL
ints.png (980.1 KB) - added by darfo 4 years ago.
ints command output
IMG_20150322_164824.jpg (1.4 MB) - added by streak 4 years ago.
IMG_20150322_164857.jpg (1.5 MB) - added by streak 4 years ago.
IMG_20150322_164959.jpg (1.4 MB) - added by streak 4 years ago.
IMG_20150322_165009.jpg (1.3 MB) - added by streak 4 years ago.
KDL2.png (1014.1 KB) - added by darfo 4 years ago.
The real KDL <blush>
ints2.png (973.5 KB) - added by darfo 4 years ago.
The real ints </blush>
syslog-tail.png (1.1 MB) - added by darfo 4 years ago.
tail of KDL syslog after General Protection Error
syslog (312.9 KB) - added by darfo 4 years ago.
After successful gcc2hybrid boot with Atheros wifi enabled

Change History (28)

Changed 4 years ago by darfo

Attachment: KDL.png added

KDL

Changed 4 years ago by darfo

Attachment: ints.png added

ints command output

comment:1 Changed 4 years ago by streak

The same thing on my NOKIA BOOKLET 3G occurs. Previously it worked.

Changed 4 years ago by streak

Attachment: IMG_20150322_164824.jpg added

Changed 4 years ago by streak

Attachment: IMG_20150322_164857.jpg added

Changed 4 years ago by streak

Attachment: IMG_20150322_164959.jpg added

Changed 4 years ago by streak

Attachment: IMG_20150322_165009.jpg added

comment:2 Changed 4 years ago by streak

i just checked that on hrev48752 atheros wifi works perfectly on Nokia Booklet 3G so between 48752 and 48926 something was changed and wifi stopped to work.

comment:3 Changed 4 years ago by korli

Why do you say "KDL in atheroswifi"?

comment:4 Changed 4 years ago by darfo

Argh. The first KDL pictures I took on my cellphone were in atherowife but I decided they were too hard to read. Got out my camera and took pictures of what I thought was the same error. Good thing I don't work for NASA. I will try to get the correct pictures.

comment:5 Changed 4 years ago by darfo

Got the pictures but it took two tries and showed an interesting clue. I'm using a dual-boot system. When I powered up, booted linux, shutdown, and then booted Haiku it worked fine and I was able to connect the wifi fine.

When I powered off and then booted straight into Haiku the KDL happened. Please see KDL2.png and ints2.png.

Changed 4 years ago by darfo

Attachment: KDL2.png added

The real KDL <blush>

Changed 4 years ago by darfo

Attachment: ints2.png added

The real ints </blush>

comment:6 Changed 4 years ago by diver

Description: modified (diff)
Platform: Allx86-64
Summary: KDL in atheroswifi at boot time hrev48926PANIC: Unexpected exception "General Protection Exception" occurred in kernel mode!

comment:7 Changed 4 years ago by diver

Description: modified (diff)

Do you get the same KDL with gcc2hybrid builds?

The first KDL looks like registrar crash. Probably deserves it's own ticket.

Last edited 4 years ago by diver (previous) (diff)

comment:8 Changed 4 years ago by korli

Please a syslog.

comment:9 Changed 4 years ago by darfo

The system never comes up far enough to file the syslog into the file system so all I can offer is the tail of the KDL syslog output. When I mount the filesystem on Linux the log file is empty.

It will take me some time to build a gcc2hybrid but I will start on it and report back the results.

Changed 4 years ago by darfo

Attachment: syslog-tail.png added

tail of KDL syslog after General Protection Error

comment:10 Changed 4 years ago by darfo

The error does not occur with gcc2hybrid. The Atheros wifi works fine.

comment:11 Changed 4 years ago by korli

Thanks, a syslog with gcc2hybrid would be useful anyway.

Changed 4 years ago by darfo

Attachment: syslog added

After successful gcc2hybrid boot with Atheros wifi enabled

comment:12 Changed 4 years ago by korli

vendor 168c: Qualcomm Atheros
device 002b: AR9285 Wireless Network Adapter (PCI-Express)
...
x86_gcc2 [atheroswifi] (ath_pci) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1,0x6)
x86_64 [atheroswifi] (ath_pci) bus_alloc_resource(3, [16], 0x0, 0xffffffffffffffff, 0x1,0x2)
[atheroswifi] [ath] AR9285E_20 detected; using XE TX gain tables

comment:13 Changed 4 years ago by streak

On my Nokia Booklet 3G with poulsbo and atheros onboard, on GCC2H not booting so the bug it is still present, there.

comment:14 Changed 4 years ago by diver

streak, please open a new ticket, your issue doesn't seem to be related to this one.

comment:15 Changed 3 years ago by simonsouth

From looking at the disassembly it seems the problem happens in getchannels at ath_regdomain.c:549 when the driver tries to zero-out a 16-byte ieee80211_channel structure in the array passed to it:

OS_MEMZERO(ic, sizeof(*ic));

The actual exception occurs in memset_small at x86_64/arch_string.cpp:188 when writing to memory, so presumably ic is invalid at this point.

All the code that sets up the channel array seems to be contained in the driver itself though, and I can't find in the FreeBSD bug tracker anyone reporting a similar problem on that platform, so the root cause probably lies in some Haiku-specific code elsewhere.

I'm tempted to finger memset_small (especially since the driver works on other architectures) except the code is so simple it's hard to see how there could be a problem with it.

I'm convinced now this is not a stack-alignment issue (#10509), anyway.

comment:16 Changed 2 months ago by waddlesplash

Please retest with a recent nightly; the atheroswifi driver has been upgraded and a number of bugs in the WiFi stack fixed.

comment:17 Changed 2 months ago by darfo

Retested on nightly hrev52328-x86_64 with the same hardware. Works great. Good job!

comment:18 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Yay!

Note: See TracTickets for help on using tickets.