Opened 4 years ago

Closed 4 months ago

#11971 closed bug (not reproducible)

Crash during libtracker global initialization

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Kits/libtracker.so Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Booted up hrev49036 x86_gcc2 and debugger activated as soon as the Desktop appeared. Could not save reports, and killing the debugger would activate another. Tried to reboot and was greeted with a string of debugger calls...print server, media server etc.

Attachments (4)

previous_syslog (131.0 KB) - added by vidrep 4 years ago.
syslog (231.9 KB) - added by vidrep 4 years ago.
Tracker-485-debug-17-04-2015-15-27-01.report (24.4 KB) - added by vidrep 4 years ago.
syslog.2 (65.1 KB) - added by vidrep 4 years ago.

Download all attachments as: .zip

Change History (16)

Changed 4 years ago by vidrep

Attachment: previous_syslog added

Changed 4 years ago by vidrep

Attachment: syslog added

comment:1 Changed 4 years ago by anevilyak

Seems to be crashing while handling libtracker's global initialization. However, I don't see any obviously suspicious recent revisions, and I'm not able to reproduce it here. Is this happening on an existing upgraded installation, or does e.g. a clean image booted off a USB stick exhibit the same behavior? If so, can you narrow down what revision it starts appearing at for you?

comment:2 Changed 4 years ago by vidrep

I did a fresh install of hrev49020 and a pkgman update to hrev49036 last night before testing CDRecord for another ticket. This was the first cold boot after shutting down last night. I have never encountered this problem before.

comment:3 Changed 4 years ago by vidrep

Tracker crashed again today on hrev49046 x86_gcc2 while navigating an old BeOS 5 installation CD. Debug report and syslog attached.

Changed 4 years ago by vidrep

comment:4 Changed 4 years ago by anevilyak

The backtrace in that report looks completely unrelated to the originally reported crash, and probably merits its own separate ticket.

Changed 4 years ago by vidrep

Attachment: syslog.2 added

comment:5 Changed 4 years ago by vidrep

Can you rename this ticket title to something more appropriate for the bug in question? I'll open another ticket for the latest crash.

comment:6 Changed 4 years ago by anevilyak

Summary: Tracker crashCrash during libtracker global initialization

comment:7 Changed 4 years ago by waddlesplash

Does this still happen?

comment:8 Changed 4 years ago by diver

Blocked By: 11982 added
Resolution: duplicate
Status: newclosed

comment:9 Changed 4 years ago by waddlesplash

Blocked By: 11982 removed
Resolution: duplicate
Status: closedreopened

@Diver, no, these are two separate tickets. Read the entire ticket history again.

comment:10 Changed 4 years ago by diver

Hmm, isn't the crash in the attached debug report is at BCompressionAlgorithm::BAbstractInputStream::Read function which #11982 is about?

comment:11 Changed 4 years ago by waddlesplash

It is, but as AnEvilYak pointed out, that's unrelated to the crashes shown in the syslogs.

comment:12 Changed 4 months ago by waddlesplash

Resolution: not reproducible
Status: reopenedclosed
Note: See TracTickets for help on using tickets.