Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12027 closed bug (duplicate)

Zip-O-Matic fails on single folder

Reported by: mmu_man Owned by: waddlesplash
Priority: normal Milestone: R1/beta1
Component: Add-Ons/Tracker Version: R1/Development
Keywords: Zip-O-Matic Cc:
Blocked By: #12105 Blocking: #12064
Has a Patch: no Platform: All

Description

When used to zip-up a single folder, Zip-O-Matic actually chdir()s to it before running /bin/zip, which then fails to find the folder to zip.

Change History (15)

comment:1 Changed 4 years ago by bbjimmy

This should be a beta blocker

comment:2 Changed 4 years ago by waddlesplash

Blocking: 12064 added

comment:3 Changed 4 years ago by haiqu

There are two levels to this issue. First, as stated correctly above, the chdir() needs to be removed from zipperthread.cpp line 100. Once that is done you'll find that files in the home directory can be zipped but files on another volume will fail as before.

I looked over the code for a while but I don't write C++ and it all looks like spaghetti to me.

p.s. Sorry for the dup, I searched for ZipOMatic without the hyphens.

comment:4 Changed 4 years ago by AGMS

It also now (hrev49168) fails to zip up directories with a space in their name. Used to work fine for that on BeOS.

comment:5 Changed 4 years ago by waddlesplash

Owner: changed from nobody to waddlesplash
Status: newassigned

comment:6 Changed 4 years ago by waddlesplash

I looked over the code for a while but I don't write C++ and it all looks like spaghetti to me.

I do write C++, and it looks like spaghetti to me too. :P

comment:7 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev49223.

comment:8 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: closedreopened

Reverted in hrev49226. Apparently the real culprit is #12105.

Last edited 4 years ago by Janus (previous) (diff)

comment:9 Changed 4 years ago by waddlesplash

Blocked By: 12105 added
Resolution: duplicate
Status: reopenedclosed

comment:10 Changed 4 years ago by waddlesplash

Blocked By: 12105 removed

(In #12105) Bumping to 'blocker' priority, as this breaks nearly all Tracker addons.

comment:11 Changed 4 years ago by waddlesplash

Blocked By: 12105 added

comment:12 Changed 4 years ago by haiqu

This is fixed, but not very satisfactorily. Zipped directories now contain the zip, I'd expect it to be created in the parent directory.

comment:13 Changed 4 years ago by waddlesplash

This is not fixed; as you can see by the status being "duplicate" and the "blocked by" not being fixed.

comment:14 Changed 4 years ago by haiqu

This isn't a duplicate of #12105 but that *may* be the reason it's not working correctly. I'd keep the ticket open until that is confirmed. Regardless, we do get a zipfile now so it's an improvement.

comment:15 Changed 4 years ago by waddlesplash

Did you even read what I wrote? #12105 is the root cause of the issue, it's not a "may or may not be". Reading the source code makes it clear, and debugging ZOM makes it obvious.

Note: See TracTickets for help on using tickets.