Opened 4 years ago

Closed 4 years ago

#12033 closed bug (fixed)

Icon-o-Matic crashes on style change

Reported by: matjako Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/Icon-O-Matic Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Icon-o-Matic crashes when style is switched from Gradient to Color.

Steps to reproduce:

  1. Add a new style
  2. Change the new style to Gradient
  3. Change the style back to Color

At this point the program crashes in my nightly, regardless if a style is assigned to anything or not.

Attachments (1)

Icon-O-Matic-1770-debug-28-04-2015-10-48-18.report (11.5 KB ) - added by matjako 4 years ago.
Crash report

Download all attachments as: .zip

Change History (3)

by matjako, 4 years ago

Crash report

comment:1 by stippi, 4 years ago

Thanks for the report. This is most likely caused by a recent change from another Haiku developer which fixes a memory leak. The Style leaked the gradients. This crashing bug may have always been there, but previously it was hidden, since the gradient was never freed. Maybe the fix is incorrect, and the gradient is freed the wrong way (deleted versus unreferenced)... I need to check.

comment:2 by stippi, 4 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev49158.

Note: See TracTickets for help on using tickets.