Opened 4 years ago

Closed 5 days ago

#12107 closed bug (invalid)

Cannot build from sources on HDD when logged on via USB stick - hrev49218

Reported by: haiqu Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Security key generation Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I royally screwed up networking while trying to get a headless Raspberry Pi working. I think it may have something to do with misuse of SSH. Anyhow, that's when the fun began.

I downloaded the latest nightly and dd'ed it to a stick, booted and installed it to the HDD. Still no wifi. In short, I have wifi on the stick, but not on the HDD. So to do a daily build I decided to boot via the USB stick, switch to the HDD partition with the sources on it and build, but this fails completely. I can update git sources, and the build starts but then crashes almost immediately.

Sometimes I get a segment violation, usually vfork: out of memory. (N.B. I have tons of VM set but the system will only use 80MiB or so when booted from a small USB partition.)

If anyone knows how to manually regenerate SSH (and other) keys, this may fix the issue. At least then I can boot off the HDD with wifi again.

Change History (7)

comment:1 Changed 4 years ago by haiqu

Further data, possibly relevant: the system has 1GiB of RAM fitted.

comment:2 Changed 4 years ago by diver

Perhaps your swap file is not enabled on USB?

IIRC, you can regenerate your SSH keys with ssh-keygen -A.

comment:3 Changed 4 years ago by haiqu

I have a 1Gb swapfile set up on one of the HDD partitions, it seems to make no difference. VM stays at 81.05MB no matter what. I'll try a keygen, thanks.

comment:4 Changed 4 years ago by haiqu

Regenerating SSH failed to affect the issue. I'm opening a separate ticket for that.

comment:5 Changed 4 years ago by pulkomandy

You can configure the swap in preferences/Memory. By default the swap file is on the boot volume but you can change there. It is a known problem of Jam that it needs a lot of memory because it uses vfork to spawn tools (it could use posix_spawn or load_image instead).

With only 1GiB of RAM you will probably need 2 or 3GiB of swap to build the system. This is part of the build requirements. The nightlies when dd'ed this way have not enough free space, so you will need to move the swap elsewhere than the boot volume.

comment:6 Changed 4 years ago by haiqu

See comment 3. Already tried that.

comment:7 Changed 5 days ago by waddlesplash

Resolution: invalid
Status: newclosed

You said you tried 1GB of swap, not 2 or 3GB. That would be the difference here.

Note: See TracTickets for help on using tickets.