Opened 13 years ago

Closed 13 years ago

#1211 closed bug (invalid)

KVM returning exception 13 (0) booting Haiku (and crash)

Reported by: leleobhz Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

After start kvm, when show the haiku graphics (fast), it crashes. Works without kvm (-no-kvm opt), with returns:

leleobhz@zorg:~/COISASQUEGOSTO/OS/BeOS/HAIKU$ kvm -hda haiku.image unhandled vm exit: 0x80000021 rax 0000000000000000 rbx 0000000000000000 rcx 0000000000000000 rdx 0000000000000600 rsi 0000000000000000 rdi 0000000000000000 rsp 0000000000000000 rbp 0000000000000000 hrev8 0000000000000000 hrev9 0000000000000000 hrev10 0000000000000000 hrev11 0000000000000000 hrev12 0000000000000000 hrev13 0000000000000000 hrev14 0000000000000000 hrev15 0000000000000000 rip 000000000000fff0 rflags 00023002 cs f000 (ffff0000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0) ds 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0) es 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0) ss 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0) fs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0) gs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0) tr 0000 (08850000/00002088 p 1 dpl 0 db 0 s 0 type b l 0 g 0 avl 0) ldt 0000 (00000000/0000ffff p 1 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0) gdt 0/ffff idt 0/ffff cr0 60000010 cr2 0 cr3 0 cr4 0 cr8 0 efer 0 Cancelado (core dumped)

-no-acpi dont get results. Strace -f dont return notting than a lot of ioctl and the crash on final. GDB returns notting more, but give-me time for a screenshot (attached). Versions:

leleobhz@zorg:~$ dpkg -l kvm Desejado=U=Desconhecido/Instalar/Remover/aPagar/H=Manter | status=Não/Instalado/arquiv.-Config./U=Descomp./Falhou-config/H=semi-inst.

|/ Erro?=(nenhum)/H=Mantido/precisa-Reinst./X=os dois problemas (status,Erro: maiúsculas=ruim)

/ Nome Versão

Descrição +++-=============================-=============================-=========== =============================================================== ii kvm 16-1ubuntu2 Full virtualization on x86 hardware leleobhz@zorg:~$ uname -a Linux zorg 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Mind note: KVM is a mod version of qemu to support intel and amd virtualisation. As writed in the KVM page (http://kvm.qumranet.com/):

"With certain guest operating systems, booting gives an immediate "Execption 13" or "Exception 12" message.

The problem is caused by the lack of real-mode virtualization on Intel processors. Real mode is the 16-bit instruction set used in the 8088 cpu, and is used for booting modern operating system, and by DOS. kvm uses a hack that allows most, but not all, of real mode instructions to be used. If your guest OS uses a real mode feature that kvm does not emulate, it will crash."

So is why Haiku uses unsupported real mode instructions. Someone can make it compatible?

Attachments (1)

bug_kvm_haiku_low.jpg (157.9 KB ) - added by leleobhz 13 years ago.
GDB on crash moment

Download all attachments as: .zip

Change History (2)

by leleobhz, 13 years ago

Attachment: bug_kvm_haiku_low.jpg added

GDB on crash moment

comment:1 by axeld, 13 years ago

Resolution: invalid
Status: newclosed

I don't think it's worth the effort for now.

Note: See TracTickets for help on using tickets.