Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12136 closed bug (invalid)

Closing application doesn't terminate disk activity

Reported by: haiqu Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications Version: R1/Development
Keywords: zombies Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When closing an application that is using the HDD, disk activity isn't terminated. Instance is 'find' box, which when closed keeps searching directories until it eventually runs out, at which time it will crash Tracker because the parent window isn't there any longer.

Instance is Terminal, which may be used to compile a program and so will keep going for wuite some time unnecessarily.

I believe the correct response to an application being closed is to immediately cancel all disk activity, it must be assumed that the user is either no longer interested in the result or is trying to kill a rampant process.

Attachments (2)

Tracker-509-debug-16-06-2015-09-47-59.report (26.1 KB) - added by haiqu 4 years ago.
Tracker debug report
syslog (398.8 KB) - added by haiqu 4 years ago.
syslog

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by pulkomandy

What are you doing exactly? Doing "find /" in Terminal then hitting ctrl+C stops it immediately. Closing Terminal also kills find immediately here, and there is no crash.

For writing, it is expected that the writes will continue, until everything is flushed (we have a disk cache).

If you have a crash, please attach a debug report.

comment:2 Changed 4 years ago by haiqu

A bug report for Tracker crashing wouldn't be distinctive, it happens at least daily here anyhow. I'm doing a 'find xyz.h' then closing the finder box without ctrl-C. i.e. a read-only search.

Evidently your system behaves differently. I've had to force a reboot to stop processes occasionally.

comment:3 Changed 4 years ago by pulkomandy

But it doesn't happen here. So, please include the debug report for that (maybe in a separate ticket if you think the issue is unrelated). It may at least give some hints as to what is happening.

A copy of syslog (available in /var/log/syslog) may also provide some info. Are there for example messages from the low_resource_manager there?

comment:4 Changed 4 years ago by haiqu

Attached.

Changed 4 years ago by haiqu

Tracker debug report

Changed 4 years ago by haiqu

Attachment: syslog added

syslog

comment:5 Changed 4 years ago by pulkomandy

Thanks. I see several errors from BFS in your log. Does running checkfs help with the problem? ("checkfs /boot" to check the boot volume)

Your tracker crash seems to be #11982.

In your syslog there is a lot more than just running find, I can see you are using ffmpeg and installing vlc.

I see that the low_resource_manager is switching between "normal" and "note". Do you have a swap file enabled (check in preferences/VirtualMemory)? Maybe what you see is just the system swapping things out of RAM to make space for the file cache (see https://dev.haiku-os.org/ticket/11221 for a related task)?

comment:6 Changed 4 years ago by axeld

Resolution: invalid
Status: newclosed

comment:7 Changed 4 years ago by haiqu

checkfs /boot - no errors VM is set to default settings. 2GB size, using 297MB, managed automatically.

Note: See TracTickets for help on using tickets.