Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12168 closed bug (invalid)

selfmade hpkg does not install link to non-package menu folder

Reported by: lelldorin Owned by: stippi
Priority: normal Milestone: R1/beta1
Component: File Systems/packagefs Version: R1/Development
Keywords: Cc: lelldorin
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I create a hpkg with my HPKGCreartor. Into the files for the package i add a link for the menu into non-packaged/data/deskbar/menu/Applications/TutorialFinder. The HPKG does create without any problems and now HaikuDepot open it, then i double click it. Now installing is without problems too, but the link to them menu does not installed, only the apps folder with my program file.

Then i create link using ln into this folder it creates a link into them Applications menu.

Attachments (1)

TutorialFinder.hpkg (495.6 KB ) - added by lelldorin 4 years ago.
package created with HPKHCreator

Download all attachments as: .zip

Change History (7)

by lelldorin, 4 years ago

Attachment: TutorialFinder.hpkg added

package created with HPKHCreator

comment:1 by humdinger, 4 years ago

I think that the non-packaged folder is "untouchable" when installing a hpkg is by design. I don't know the internals enough, but I think the ticket is invalid.

You should've put the link into "data/deskbar/menu/Applications/".

comment:2 by stippi, 4 years ago

Component: Applications/HaikuDepotFile Systems/packagefs
Resolution: invalid
Status: newclosed

Exactly. The non-packaged folder, as its name implies, contains only stuff that is non-packaged, i.e. "not from any package". So packages cannot make stuff appear inside those folders, since then that stuff would be "from a package".

comment:3 by lelldorin, 4 years ago

this is correct i think so too. my first try are to use data/deskbar/menu/Applicatiobs but it is read only

Last edited 4 years ago by lelldorin (previous) (diff)

comment:4 by stippi, 4 years ago

I think you might have a misunderstanding here. I was not aware of the existence of "HPKGCreator" and I have never used it. When I created packages, I created an folder structure anywhere in the writable file system (for example in /boot/home/packages/my_package_contents) which matched the folder hierarchy of the system folder (only the folders I need). For example, I might have a folder "/boot/home/packages/my_package_contents/data/deskbar/menu/Applications/" and in that folder I might have a relative link to my application. Then I use the package command line tool to create a package with those exact contents, only that they will later be merged with the actual system folders.

comment:5 by pulkomandy, 4 years ago

Also, it is useful to know that Deskbar uses "virtual folders" to create the complete menu, so the menu is not a single folder anymore. It is instead a merge of several different folders, including the packaged and non-packaged variants.

The result of this is:

  • entries from packages goes in the packaged data/deskbar/menu/Applications/
  • entries from outside of packages goes in non-packaged/data/deskbar/menu/Applications/
  • Deskbar will show entries from both directories

comment:6 by lelldorin, 4 years ago

Ok thank you i get it: ln -rs /path/to/app/programname /path/to/data/deskbar/menu/Applications/programname

Note: See TracTickets for help on using tickets.