Opened 4 years ago

Closed 4 years ago

#12189 closed bug (no change required)

Cannot install to Samsung SSD

Reported by: haiqu Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Just bought a Samsung 840 120GB SSD for development work. (Not 840 EVO, the original version.)

Created partitions, copied everything across, then tried an install from the old HDD. The install failed to load Deskbar, haiku_loader, kernel_x86, runtime_loader and Tracker onto the new drive.

So, I copied them over manually and did a 'makebootable' but it still fails to boot. The I attempted to install BootManager but it shows up an 'Incompatible format' error.

The drive is being identified as /dev/disk/ata/0/master/

Change History (6)

comment:1 Changed 4 years ago by haiqu

p.s. I also tried downloading the latest nightly and installing from an 8GB memory stick, same problem.

comment:2 Changed 4 years ago by diver

Component: Drivers/Disk/ATA- General

'Incompatible format' means that you don't have an MBR on your disk. How did you create the partitions?

I don't think you can copy system files manually since they live in a package. Did you use Installer? What do you mean by "The install failed to load..."?

comment:3 Changed 4 years ago by haiqu

SSD was partitioned and formatted from blank with Haiku using DriveSetup.

"The installer didn't copy those files onto the SSD", is what I mean when I say "the installer failed to load ..." I suspect the installer saw some problem and decided it wasn't going to work. I haven't looked at the associated code, can't build a hybrid currently on Haiku so not much point.

I used the installer from the original HDD and from USB and had the same result.

comment:4 in reply to:  3 Changed 4 years ago by bonefish

Replying to haiqu:

"The installer didn't copy those files onto the SSD", is what I mean when I say "the installer failed to load ..."

Installer is not supposed to copy these files. It only copies the packages containing them.

comment:5 Changed 4 years ago by haiqu

Found a workaround that got me an install on my T60 laptop.

  1. Put the SSD into the internal drive position, which is on the SCSI bus.
  2. Delete all partitions and redo them.
  3. Install from old HDD, which is now in the caddy on the ATA bus.
  4. Run 'BootManager' from the terminal and install it onto the SSD.
  5. Reboot, changing the bios to boot off the internal (SSD) drive.

Viola! It works.

Note: Another issue noted is that the MBR won't save since it tries to save to a non-existent directory (~/config/settings/bootman/MBR). Manually creating that directory fixes this issue, but it will need a '-f' switch in the script, or something.

comment:6 Changed 4 years ago by diver

Resolution: no change required
Status: newclosed
Note: See TracTickets for help on using tickets.