Opened 4 years ago

Closed 3 years ago

#12209 closed enhancement (fixed)

USB 2.0 (EHCI) Mass Storage doesn't work in VirtualBox

Reported by: waddlesplash Owned by: mmlr
Priority: normal Milestone: Unscheduled
Component: Drivers/USB/EHCI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In VirtualBox 5.0, Haiku doesn't recognize a mass storage device connected via EHCI. Using OHCI instead (USB 1.0) works and both reading and writing works perfectly.

Relevant syslog output:

KERN: PCI:   device 265c: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
KERN: PCI:   info: Serial bus controller (USB controller, EHCI)
KERN: usb ehci -1: no extended capabilities register
KERN: usb ehci -1: successfully started the controller
KERN: usb error ehci -1: error while getting the device descriptor

Change History (2)

comment:1 by mmlr, 4 years ago

This should be fixed in hrev50146. Note however that I wasn't able to fully get things working due to an apparent interrupt issue that would later let transfers time out. Please check if you can reproduce the latter.

comment:2 by waddlesplash, 3 years ago

Resolution: fixed
Status: newclosed

Indeed it now works properly. Thanks!

Note: See TracTickets for help on using tickets.