Opened 4 years ago

Closed 3 years ago

#12348 closed bug (fixed)

Boot Failure Lenovo Ideapad z580

Reported by: DFergFLA Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When booting latest nightly (rev 49600) I get:

PANIC: did not find any boot partitions!

I am booting from a CD. I also get the same thing if I create a USB and try to boot. I have the latest BIOS available for this laptop. I have also tried "safe mode" booting and get the same problem. Someone suggested turning off USB 3.0 but I do not have that option. I can only turn on/off legacy support for USB. I have tried both.

the specs are listed here: http://shop.lenovo.com/us/en/laptops/ideapad/z-series/z580/#tab-tech_specs

Attachments (2)

SYSLOG00.TXT (86.2 KB) - added by DFergFLA 4 years ago.
SYSLOG00.2.TXT (60.9 KB) - added by DFergFLA 4 years ago.
Syslog 10\3

Download all attachments as: .zip

Change History (17)

comment:1 Changed 4 years ago by DFergFLA

I can get you more information if needed. I just need to know what you need and how to get it for you.

Thanks

Donald

comment:2 Changed 4 years ago by mmlr

Please try with a revision >= hrev49602 as there was problem with AHCI that could break support for booting from SATA devices.

Regarding USB, the spec lists 2 USB 2.0 ports as well, so make sure to connect the USB stick to one of them (the ones that don't have blue sockets).

If both still fails, please try to get the syslog output (see the syslog section in ReportingBugs).

comment:3 Changed 4 years ago by DFergFLA

Is 49602 available? I don't see it on the nightly download page?

Changed 4 years ago by DFergFLA

Attachment: SYSLOG00.TXT added

comment:5 Changed 4 years ago by DFergFLA

Tested with 49606, sadly this did not resolve my issue. I have attached a syslog.

comment:6 Changed 4 years ago by DFergFLA

Can I request that someone please take a look at this?

comment:7 Changed 4 years ago by DFergFLA

Downloaded 49662, no joy. Attaching an other log just in case something has changed.

Changed 4 years ago by DFergFLA

Attachment: SYSLOG00.2.TXT added

Syslog 10\3

comment:8 Changed 4 years ago by diver

Maybe it has something to do with this:

ahci: device signature 0xeb140101 (ATAPI)
ahci: sata_request::finish ATA command 0xa0 failed: status 0x51, error 0x30
ahci: sata_request::finish ATAPI packet 28 00 00 02 1e 90 00 00 02 00 00 00 00 00 00 00 (len 10)

In any case attach your syslog after booting from usb, it should be different.

comment:9 Changed 4 years ago by DFergFLA

I am able to boot from USB. I would like to see the underlying problem resolved at some point.

comment:10 Changed 4 years ago by korli

It seems the boot CD is a multisession one, first session is Haiku, second is Aros. I'm not sure it should be that way. Maybe try to burn an anyboot image.

comment:11 Changed 4 years ago by pulkomandy

@korli: are you sure about that? To me it looks like Haiku (plain ISO) on a CD and AROS "live CD" on an USB drive.

Still, maybe the anyboot works better than the plain ISO.

comment:12 Changed 4 years ago by DFergFLA

I am not entirely sure where the AROS one is/was coming from. I did have AROS on this laptop. I didn't have an AROS usb in the laptop when I was running the Haiku installer, so it isn't that. I am as sure as I can be that I closed the session. I am working on some things in an other ticket. Give me a day or so and I can post an other syslog and see if that AROS thing is still around. I think it may have been on the HD and could be causing me other problems too. It may have been coming from the HD.

comment:13 Changed 3 years ago by kallisti5

AHCI was reworked recently... is this still an issue?

comment:14 Changed 3 years ago by DFergFLA

I am not getting this anymore. I do have problems booting from CD but not USB but that is a separate ticket.

comment:15 Changed 3 years ago by kallisti5

Resolution: fixed
Status: newclosed

Thanks for confirming! Marking this one resolved.

Note: See TracTickets for help on using tickets.