Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12454 closed bug (fixed)

Missing items in deskbar

Reported by: luroh Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/launch_daemon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev49803, gcc2h, VirtualBox 5.0.8.

Looks like the missing deskbar icons problem is back again, I only have the time thingy here. It worked in hrev49707 a few weeks ago but I recall it was at least semi-broken some time before hrev49803.

Change History (12)

comment:1 Changed 3 years ago by axeld

Status: newin-progress

The last change in the launch_daemon had some unexpected consequences, working on it.

comment:2 Changed 3 years ago by axeld

Resolution: fixed
Status: in-progressclosed

Fixed in hrev49819.

comment:3 Changed 3 years ago by luroh

Resolution: fixed
Status: closedreopened

Almost, still missing ProcessController here, hrev49821, gcc2h.

comment:4 Changed 3 years ago by axeld

After a new install? If it was not added during the first start, it will never be added later (unless you do that manually). Did you wait a long time before you continued to the desktop from the FirstBootPrompt? How many CPUs?

In any case, I cannot reproduce this anymore.

comment:5 Changed 3 years ago by luroh

Yes, after a new install. I have since done a clean build, currently at hrev49824 and I'm still seeing the problem. I waited around 10 seconds and checked that there was no ongoing disk activity before pressing the 'Boot to Desktop' button at firstbootprompt. One CPU.

comment:6 Changed 3 years ago by luroh

Update: I'm seeing the same when building to disk and booting on real hardware. Hold on though, I have discovered a custom kernel_debug_config.h in user_config_headers. Rebuilding clean now to check if that one might be the culprit.

comment:7 Changed 3 years ago by axeld

I think I have an idea of what's going on, I'll have a closer look tomorrow.

comment:8 Changed 3 years ago by luroh

Thank you. Rebuilding without the custom kernel_debug_config.h didn't make any difference.

comment:9 Changed 3 years ago by luroh

Anything needed from my side here, seeing as I'm able to reproduce the problem?

comment:10 Changed 3 years ago by axeld

No, thank you, I just didn't find the time yet to work on it, as it's a bit more involved, and requires some planning.

comment:11 Changed 3 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Fixed in hrev49892.

comment:12 Changed 3 years ago by luroh

Confirmed, thank you.

Note: See TracTickets for help on using tickets.