Opened 4 years ago

Closed 4 years ago

#12492 closed bug (fixed)

app_server crashes when opening a text file

Reported by: un_spacyar Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

I have hrev49730 x86_gcc2

I get the error detailed in the attached image, when I try to open specific text file.

I tried using the checkfs tool without success. Also, I tried to open the file with another editor (HotEdit) with the same error.

vm_page_fault: thread "w:1229:Packages" (1235) in team "app_server" (332) tried to read address 0x766919ec, ip 0x157ba4e ("libroot.so_seg0ro" +0xafa4e)
debug_server: Thread 1235 entered the debugger: Segment violation
stack trace, current PC 0x157ba4e  malloc__Q28BPrivate10threadHeapUl + 0x4ca:
(0x70932f38)  0x157c34c  malloc + 0x184
(0x70932f68)  0x14f49fd  __nw__FUlRC9nothrow_t + 0x29
(0x70932f98)  0x750127  AddConstraint__Q217LinearProgramming10LinearSpecdPQ217LinearProgramming8VariabledT2Q217LinearProgramming12OperatorTypeddd + 0x11b
(0x70932fe8)  0x73fed2  Init__10WindowAreaP8SATGroup + 0xd6
(0x70933058)  0x743595  AddWindow__8SATGroupP9SATWindowP3TabN32 + 0xb51
(0x709330b8)  0x747d34  GetGroup__9SATWindow + 0xb4
(0x70933118)  0x74a87f  _ActivateWindow__12StackAndTileP9SATWindow + 0x2b
(0x70933158)  0x74a259  WindowActivated__12StackAndTileP6Window + 0x35
(0x70933188)  0x6781ab  NotifyWindowActivated__17DesktopObservableP6Window + 0x53
(0x709331b8)  0x66fd66  ActivateWindow__7DesktopP6Window + 0x82
(0x70933208)  0x670660  ShowWindow__7DesktopP6Window + 0xc4
(0x70933248)  0x69f686  _Show__12ServerWindow + 0x8a
(0x70933278)  0x6a0456  _DispatchMessage__12ServerWindowlRQ28BPrivate12LinkReceiver + 0x21a
(0x709333a8)  0x6a85bc  _MessageLooper__12ServerWindow + 0x27c
(0x70933428)  0x683c70  _message_thread__13MessageLooperPv + 0x28
(0x70933458)  0x14fdd43  thread_entry + 0x23

Attachments (4)

DwarfManager3.jpg (357.4 KB ) - added by un_spacyar 4 years ago.
syslog.old (512.0 KB ) - added by un_spacyar 4 years ago.
app_server-332-debug-22-11-2015-20-13-13.report (52.3 KB ) - added by un_spacyar 4 years ago.
text_file.zip (781 bytes ) - added by un_spacyar 4 years ago.
the file that causes the trouble

Download all attachments as: .zip

Change History (17)

by un_spacyar, 4 years ago

Attachment: DwarfManager3.jpg added

comment:1 by ttcoder, 4 years ago

Does not look like a BFS problem, more like an app_server crash (see "a:" prefixes); does it leave a trace in the syslog ? Please post it if so.. If it does and if it's reproducible it might help with the other ongoing ticket about app_server who knows

by un_spacyar, 4 years ago

Attachment: syslog.old added

comment:2 by un_spacyar, 4 years ago

Hello. I attached the syslog. Please, look for:

KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x10004, ip 0x1562dcf, write 0, user 1, thread 0x23e KERN: vm_page_fault: thread "a:572:x-vnd.Haiku-StyledEdit" (574) in team "app_server" (334) tried to read address 0x10004, ip 0x1562dcf ("libroot.so_seg0ro" +0xaedcf)

It's not 100% reproducible, but about 95% reproducible with the same text file... :-)

comment:3 by ttcoder, 4 years ago

Looks like a new bug; seems FreeType(?) stumbles on a heap corruption Probably an admin will change component from 'General' to 'app_server' to bring more attention to this ticket

comment:4 by diver, 4 years ago

Component: - GeneralServers/app_server
Description: modified (diff)
Milestone: UnscheduledR1
Owner: changed from nobody to axeld
Summary: Error "debbugger for team" when opening a text fileapp_server crashes when opening a text file

comment:5 by pulkomandy, 4 years ago

When you are at the "debugger" prompt, use the "save-report" command, it will create a debug report on your desktop which you can then attach here. Also attaching the problematic file would help.

comment:6 by un_spacyar, 4 years ago

Hello Pulkomandy! I'm attach the report.

comment:7 by un_spacyar, 4 years ago

I'm also attach the text file (I submit it zipped to preserve the attributes).

by un_spacyar, 4 years ago

Attachment: text_file.zip added

the file that causes the trouble

comment:8 by vidrep, 4 years ago

hrev49917 x86_gcc2 I was editing the package repository files with StyledEdit when the debugger was triggered. The relevant output from the syslog is pasted below:

vm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x1bd, ip 0x2179671, write 0, user 1, thread 0x1d7
vm_page_fault: thread "event loop" (471) in team "app_server" (408) tried to read address 0x1bd, ip 0x2179671 ("app_server_seg0ro" +0x7c671)
debug_server: Thread 471 entered the debugger: Segment violation
stack trace, current PC 0x2179671  SetFocusWindow__7DesktopP6Window + 0x215:
  (0x72c259b8)  0x2176ed5  ActivateWindow__7DesktopP6Window + 0x27d
  (0x72c25a08)  0x2260aea  _ActivateWindow__12StackAndTileP9SATWindow + 0x11a
  (0x72c25a48)  0x22603e1  WindowActivated__12StackAndTileP6Window + 0x35
  (0x72c25a78)  0x217f0fa  NotifyWindowActivated__17DesktopObservableP6Window + 0x52
  (0x72c25aa8)  0x2176cda  ActivateWindow__7DesktopP6Window + 0x82
  (0x72c25af8)  0x21cc5c1  MouseDown__22DefaultWindowBehaviourP8BMessageG6BPointlRlT4 + 0x305
  (0x72c25b78)  0x21bedfb  MouseDown__6WindowP8BMessageG6BPointRC11ClickTargetRlR11ClickTarget + 0x77
  (0x72c25be8)  0x21744a5  Filter__11MouseFilterP8BMessagePP11EventTargetPlT1 + 0x1fd
  (0x72c25c68)  0x2187436  _EventLoop__15EventDispatcher + 0x29e
  (0x72c25cf8)  0x2187bc7  _event_looper__15EventDispatcherPv + 0x1f
  (0x72c25d28)  0xbe2333  thread_entry + 0x23
Last edited 4 years ago by pulkomandy (previous) (diff)

comment:9 by vidrep, 4 years ago

After a reboot, attempting to open those same text files results in an error message:

Could not open "Haiku" with application "Tracker" (Invalid Arguement). Would you like to find some other suitable application?

comment:10 by un_spacyar, 4 years ago

Cant be reproduced since upgraded to hrev50085. I can open the textfile without problems. ¿Fixed?

vidrep, do you still have the issue?

comment:11 by vidrep, 4 years ago

I'm not seeing the issue anymore. The text_file you attached also works on the latest hrev.

comment:12 by un_spacyar, 4 years ago

I think this ticket could be closed.

Thanks!

comment:13 by diver, 4 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.