Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12517 closed bug (duplicate)

mp3 file crash media player

Reported by: AlienSoldier Owned by: nobody
Priority: high Milestone: R1/beta1
Component: Audio & Video/Codecs Version: R1/Development
Keywords: Cc:
Blocked By: #12509 Blocking:
Platform: x86

Description

I notice webm video also crash it (video continue to work, no sound). mp4 video work fine with sound. hrev49906 (i noticed that a few version back, and i don't update frequently)

Change History (16)

comment:1 by SeanCollins, 6 years ago

I also have MP3 crash in mediaplayer as well attaching crash report, not seen in nighly from last week, new regression

comment:2 by diver, 6 years ago

Blocked By: 12509 added
Resolution: duplicate
Status: newclosed

comment:3 by bruno, 6 years ago

This Ticket is about Haiku Rev.49912 not able to play some audiofiles. So this ticket should be reopened!

Media Player is crashing while trying to play: mp3 and ogg files... wav files are working though... The Vidoefiles are working too! mp4, mov, avi...

vidrep wrote in bug#12509: There is a difference in behavior due to the ffmpeg version being used. I am only testing video playback - not mp3, wav, ogg or any other audio formats. Those should probably be in a separate ticket.

Last edited 6 years ago by bruno (previous) (diff)

comment:4 by bruno, 6 years ago

should be reopened as own ticket!

comment:5 by diver, 6 years ago

Backtraces in #12509 are exactly the same. So it is likely an exact same problem.

in reply to:  5 comment:6 by bruno, 6 years ago

Replying to diver:

Backtraces in #12509 are exactly the same. So it is likely an exact same problem.

in #12509 the problem is about videofiles!

...now in hrev49912 videofiles work but audiofiles still does`nt..

comment:7 by diver, 6 years ago

Video files can also contain audio tracks, you know :)

comment:8 by vidrep, 6 years ago

What we need to do is figure out which audio formats are causing a crash and on which ffmpeg revision.

comment:9 by bruno, 6 years ago

Yes I know that Videofiles contain Audiofiles as well ;-)... But the videofiles that I tested all works just fine, only the mp3 and .ogg files seems to have problems with the MediaPlayer!

If I try to play the audiofiles with the "Open Cubic Player" (AudioPlayer ported from DOS) they just work fine!

Note: See TracTickets for help on using tickets.