Opened 3 years ago

Closed 3 years ago

#12519 closed bug (duplicate)

Web+ - Crashes appserver after 18h plus running

Reported by: joy Owned by: jua
Priority: high Milestone: R1/beta1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #12478 Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

hrev49798 to hrev49895 (At least). Web+ crashes app_server after 18 hours plus running.

After i update Haiku after BeGeistert 029 i have gotten KDL that i can't recover from with out a reboot.

It happens when Web+ been running at least for 18hours and i go to the webpage for Transmission, that i always have in an open tab. There i choose "Add torrent", choose the .torrent, tick the box for "Auto Start". Some time it crashes there or when i press "OK".

</div>
<div class="panel window" style="display: none; width: 608px; left: 311.5px; top: 246px; z-index: 9005;">
<div class="panel-header panel-header-noborder window-header" style="width: 608px;">
<div class="panel-title" style="">Add Torrent</div>
<div class="panel-tool">
<a class="panel-tool-close" href="javascript:void(0)">
</a></div></div>
<div id="dialog-torrent-add" title="" class="panel-body panel-body-noborder window-body" style="overflow: hidden; width: 606px; height: 364px;">
<div class="panel" style="width: 606px;">
<div title="" class="panel-body panel-body-noheader panel-body-noborder dialog-content panel-noscroll" style="width: 606px; height: 364px;">
<div class="easyui-layout layout" data-options="fit:true" style="width: 606px; height: 364px;">

Attachments (7)

jquery.easyui.min.js (287.7 KB) - added by joy 3 years ago.
transmission.jpg (68.5 KB) - added by joy 3 years ago.
Picture of the GUI
Pagesource.html (44.1 KB) - added by joy 3 years ago.
image.jpeg (4.7 MB) - added by joy 3 years ago.
Picture of the KDL
image.2.jpeg (2.5 MB) - added by joy 3 years ago.
Debugger and BT
app_server-427-debug-10-12-2015-23-30-08.report (252.5 KB) - added by joy 3 years ago.
App_server crash on hrev49911
app_server-553-debug-26-12-2015-14-53-53.report (160.2 KB) - added by Paradoxon 3 years ago.
App Server Crash after some minutes of Web+ use

Change History (13)

Changed 3 years ago by joy

Attachment: jquery.easyui.min.js added

Changed 3 years ago by joy

Attachment: transmission.jpg added

Picture of the GUI

Changed 3 years ago by joy

Attachment: Pagesource.html added

Changed 3 years ago by joy

Attachment: image.jpeg added

Picture of the KDL

comment:1 Changed 3 years ago by diver

Description: modified (diff)
Owner: changed from pulkomandy to jua
Status: newassigned

This is not a KDL but an app_server crash. Could you reproduce it and type save-report command in the Debugger prompt? After reboot debug report should be on your Desktop (or in home?). Additionally, you can type bt there and take a picture of a back trace.

Changed 3 years ago by joy

Attachment: image.2.jpeg added

Debugger and BT

Changed 3 years ago by joy

App_server crash on hrev49911

comment:2 Changed 3 years ago by joy

This time the app_server crashed after 24 hours.

comment:3 Changed 3 years ago by diver

Blocked By: 12478 added
Component: Applications/WebPositiveServers/app_server

Thanks for the debug report, this makes it a dupe of #12478.

comment:4 Changed 3 years ago by joy

Still exist in hrev49918

comment:5 Changed 3 years ago by joy

Still exist in hrev49937

Changed 3 years ago by Paradoxon

App Server Crash after some minutes of Web+ use

comment:6 Changed 3 years ago by pulkomandy

Resolution: duplicate
Status: assignedclosed

Apparently Jua forgot to mark this one as "duplicate", and the duplicated ticket is now closed.

Note: See TracTickets for help on using tickets.